Frage von nurXXX, 56

Wie lautet die Excel formel? Möchte rechts auf der Tabelle alle Rechnungsnummern der CC-Fälle aufgelistet haben?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 32

Dummerweise zeigst Du keine Spalte-/ Zeilenköpfe.
Ich nehme einfach mal an "Rechnung" steht in B4, dann diese Formel in E5 und runterkopieren:

{=WENNFEHLER(INDEX($B$1:$B$1000;KKLEINSTE(WENN($C$5:$C$1000="CC";ZEILE($C$5:$C$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Bereiche musst Du natürlich anpassen.
Klappt es?

Kommentar von nurXXX ,

nein leider nicht :(

Kommentar von Oubyi ,

Tja, da wirst Du leider nicht drumherum kommen zu erklären, was leider nicht klappt.
Das mindeste, was ich erwartet habe ist, dass Du die Zelladressen verrätst und Deine angepasste Formel zeigst.
SO ist Dir leider nicht zu helfen.

Kommentar von Oubyi ,

Danke fürs

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 39

Am einfachsten ist es, einen Filter zu setzen und die gefilterten Werte zu kopieren.

Es geht aber auch mittels Matrixformel. Dazu benötigst du KKLEINSTE, ZEILE und WENN, wenn ich mich nicht irre. 

Antwort
von Herb3472, 41
=WENN(Bn = "CC"; An; "")

Wobei A, B = Spalte, n = Zeilennummer


Kommentar von nurXXX ,

könntest du mir die formel genauer aufschreiben

mit zahlen anhand meiner tabelle

Kommentar von Herb3472 ,

Du hattest in deinem Beispiel keine Spalten und Zeilen angegeben, aber ok:

D1 [=WENN(B1 = "CC"; "A1;"")]

D2 [=WENN(B2 = "CC"; "A2;"")]

D3 [=WENN(B3 = "CC"; "A3;"")]

In eckiger Klammer steht jeweils die Formel der Zellen D1 bis Dn

Kommentar von Herb3472 ,

Sorry, da hat sich ein Fehler eingeschlichen, Zellenname A natürlich ohne Anführungszeichen:

Korrekt lautet die Formel:

D1 [=WENN(B1 = "CC"; A1;"")]

D2 [=WENN(B2 = "CC"; A2;"")]

D3 [=WENN(B3 = "CC"; A3;"")]

Kommentar von nurXXX ,

es handelt sich um mehrere zellen bis zu 800

als Beispiel hatte ich ihnen dur 4/5 genannt.

 

daher denke ich dass die formel nicht so sinvoll ist :)

aber trotzdem danke

Kommentar von Herb3472 ,

Wenn Du keine Matrixformel verwenden willst (Siehe weiter oben Antwort von Oubyi), musst Du die Formel in jede Ergebniszeile kopieren. Du trägst die Formel in die oberste Zelle ein und kopierst dann die Zellen soweit nach unten wie erforderlich, indem Du die Zelle mit der Formel  an der rechten unteren Ecke "anfasst" und markierst, und dann mit gedrückter Maustaste die Markierung nach unten ziehst

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten