Frage von OlsenEgon74, 38

Wie kann nach einem Zellwert gesucht werden, damit ein anderer ausgegeben werden kann?

Hallo, ich benötige Hile bei einer Excel Formel...

Wenn ein Wort aus Zelle B2:B4 in der Zelle A2 vorkommt, soll in Zelle D2 der jeweilige Wert aus Zelle C2:C4 ausgegeben werden.

Ich probiere die ganze Zeit mit einem SVERWEIS... Komme aber nicht hin... In den Zellen B2:B4 stehen Abkürzungen, die in der Spalte A vorkommen, es stehen aber noch andere Wörter in den Zellen. Es muss quasi nach der Abkürzung in der Zelle gesucht werden. In den Zellen C2:C4 steht die Abkürzung als ausgeschriebenes Wort. Das Korrekt ausgeschriebene Wort soll dan quasi in D2 ausgegeben werden...

Ich hoffe ich konnte mich soweit verständlich ausdrücken... ;-)

Danke

Expertenantwort
von Ninombre, Community-Experte für Excel, 25

Es ist immer ganz gut, wenn du die Formel dazu schreibst, die du versuchst hast. Meist nur eine Klammer oder ähnliches. 

Das Ergebnis soll in d2 stehen, also gehört da die Formel hin. 

=sverweis(a2;b2:c4;2;falsch) 

Kommentar von OlsenEgon74 ,

Entschuldige, hätte ich selbst daran denken können...

Mein jetztiger Ansatzpunkt ist:

=INDEX(C$2:C$4;FINDEN(B$2:B$4;A2;2)>0;0)

allerdings komme ich gar nicht damit klar. Muss aber dazu sagen, dass ich kein Excel-Brain bin... Daher tu ich mich mit den Formeln sehr schwer...

Folgende Situation:

In Spalte A stehen Artikelbeschreibung mit div. Abkürzungen. Unteranderem gibt es Artikel die die Abkürzung

  • verz.
  • verchr. oder
  • verg.

beinhalten.

Ich möchte, dass in Spalte D das "Klarwort" ausgegeben wird. Eigentlich dachte ich an einen SVERWEIS, aber sobald sich noch anderer Text außer der Abkürzung in der Zelle befinden funktioniert dies nicht mehr... Mein SVERWEIS war dieser:

=SVERWEIS(A2;B2:C7;2;0)

Kann ich dem SVERWEIS beibringen, dass er diese Wortgruppe suchen soll?

Danke!

Kommentar von Ninombre ,

Probier es mal so: =SVERWEIS("*"&A2&"*";B2:C7;2;0)

Kommentar von Ninombre ,

die andere Variante

=INDEX(B$2:C$4;VERGLEICH(A2&"*";B2:B4;0);2)

über das Finden kann man nicht den Bereich absuchen, nur innerhalb der Zelle.

Kommentar von OlsenEgon74 ,

Habe diesen Ansatz gerade noch probiert, der aber auch nur funktioniert wenn sich nur die Abkürzungsform in der Zelle befindet. Sobald die Abkürzung mit einem "." abgeschlossen wird oder noch andere Wörter in der Zelle stehen, werden keine Werte mehr ausgegeben...

=WENN(ISTFEHLER(VERGLEICH(B2;$A$1:$A$100;0));"";C2)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten