Wie kann man bei Excel eine Tabelle ohne Lücken zusammenfassen?

... komplette Frage anzeigen

2 Antworten

Leg doch einfach einen Autofilter drüber und nimmt den Haken bei (Leere) raus.

Excel 2010: Start → Sortieren und Filtern → Filtern

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von willemsenftw
27.07.2016, 15:47

Das funktioniert irgendwie nicht mit Excel 2016

Und das Problem ist, dass die "leeren" Zellen, ja gar nicht wirklich leer sind

0

Angenommen in A1:A10 steht der Lückentext.
Dann diese Formel in B1 und runterkopieren:

{=WENNFEHLER(INDEX($A$1:$A$10;KKLEINSTE(WENN($A$1:$A$10<>"";ZEILE($A$1:$A$10));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?
Habe ich Dich richtig verstanden?


Antwort bewerten Vielen Dank für Deine Bewertung