Frage von mrm0le, 41

Wie kann ich Spaltenwerte in Excel wie folgt addieren, wenn wir davon ausgehen das 10 Werte existieren. 10 neue Werte sollen entstehen. 1+2; 1+2+3; usw...?

Expertenantwort
von DeeDee07, Community-Experte für Excel, 24

Zunächst mal, Spalten sind senkrecht, Zeilen waagerecht. Das sorgt offensichtlich immer wieder für Verwirrung.

Wenn du z.B. in B2 die Summe aus A1+A2, in B3 die Summe aus A1+A2+A3 usw. stehen haben möchtest, lautet die Formel
=SUMME(A$1:A2)
Diese Formel runterkopieren. Durch das $ bleibt dabei in der Formel der Wert fixiert.

Solltest du die kumulierte Summe nicht nach unten in Spalte B kopieren wollen, sondern nach rechts in z.B. Zeile 1, lautet die Formel
=SUMME(INDIREKT("A1:A"&SPALTE(B1)))

Kommentar von Oubyi ,

=SUMME(A$1:A2)
für die Spalte A ist genau richtig.

Um Werte in Zeile 1, also A1:Z1 oder ähnlich zu kummulieren muss es allerdings in A1 lauten:
=SUMME(INDIREKT("A1:"&ADRESSE(1;A1)))
und nach rechts kopieren.
A&SpalteB1 würde ja immer in Spalte A bleiben.

Kommentar von Oubyi ,

Oder, natürlich einfach, analog zur ersten Formel:

=SUMME($A1:A1)

und nach rechts ziehen.

Kommentar von DeeDee07 ,

Ich sags ja, das war nicht eindeutig mit Zeilen und Spalten. Nach dem Kommentarausschnitt (fette Hervorhebungen von mir)


in der ersten spalte steht dann =Summe(a1:a2), in der zweiten
=Summe(a1:a3), in der dritten steht dann =Summe(a1:a4) und so weiter...

bin ich davon ausgegangen, dass die Werte aus Spalte A nach rechts in einer Zeile aufaddiert werden sollen, quasi transponierte Kumulierung.

Kommentar von Oubyi ,

Ach, so meintest Du das.
Jetzt habe ich es kapiert.
Dann ist Deine Formel natürlich richtig.

Sorry für die von mir gestiftete Verwirrung.

Antwort
von mrm0le, 21

Stichwort: "Summenverteilung". Nach und nach werden Einzelwerte aufaddiert und jedesmal als neuer Wert abgespeichert. Danke trotzdem. :)

Antwort
von miranya, 30

SUMME=(a1+a2+a3)
Als Beispiel

Spalten & Reihenzahl + die anderen.
Oder einfach mit markieren in die klammer setzen.
Meinst du das?

Kommentar von mrm0le ,

nicht ganz :/ also angenommen ich habe 10 spaltenwerte, dann will ich 10 neue werte erzeugen. in der ersten spalte steht dann =Summe(a1:a2), in der zweiten =Summe(a1:a3), in der dritten steht dann =Summe(a1:a4) und so weiter... das will ich aber nicht alles von hand machen. muss ich das mit vba machen und eine schleife erstellen?

Kommentar von miranya ,

tut mir leid, ich kapier dein Vorhaben nicht. Evtl versteht es wer anders.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten