Frage von Christo2345jj, 10

Wie kann ich nur reine Zahlenwerte miteinander vergleichen und Felder die einen Fehler (z.B. #Bezug) beinhalten von dem Vergleich ausnehmen?

Ich habe in Excel 8 Werte zwischen 1 und 6 die über folgende Formel " =INDEX(B$24:B$31;VERGLEICH(KKLEINSTE(E$24:E$31+ZEILE($24:$31)%;ZEILE(A1));E$24:E$31+ZEILE($24:$31)%;0)) aut? " miteinander vergleichen werden. Für die neidrigsten 3 Werte bekomme ich den Inahlt aus den daneben liegenden Zeilen ausgegeben. Wenn nun einer dieser 8 Werte einen Fehler aufweist (z.B. #Wert) funktioniert die direkt die gesamte Formel nicht mehr. Ist es möglich von den 8 Werten nur diejenigen miteinander zu vergleichen die eine Zahl beinhalten und den Rest außen vor zu lassen ohne das die Formel ungültig wird?

Antwort
von MeikelZW, 2

Hallo Christo2345jj,
mit der „Vorprüfung“ ob eine Fehler vorliegt, etwa so:

=WENN(ISTFEHLER(E5/F5);"Nix";E5/F5)

Wobei "Nix" für Deinen Ersatzwert oder eine etwaige Fehlerbehandlung stehen soll.

Weitere, speziellere IST... (ISTNV, ISTLEER, ISTBEZUG usw.) Abfragen findest du im Funktionsassitent unter »der Rubrik „Information"«

Wenn auch Zahlen als Texte berechnet werden soll, so ist der Kunstgriff

=Wert(E5). Wenn es Excel logisch* möglich ist,

eindeutig

einen Wert im Text zu erkennen, wird daraus eine "echte" Zahl.

* so wie Val(…) in VBA oder Number(…) in Javascript

Gruß, MeikelZW

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten