Frage von raster280, 44

Wie kann ich in OpenOffice in Abhängigkeit zweiter Werte eine Zelle automatisch ausfüllen lassen?

In einer OpenOffice Calc Tabelle soll in einer Zelle in Abhängigkeit von zwei anderen Zellen automatisch ein Wert ergänzt werden. Aktuell gibt es dafür folgenden Befehl: =WENN(UND($C1>=10;$D1>=10);1;0) Sprich wenn in Zeile C Und Zeile D ein Wert größer gleich 10 steht wird eine 1 eingetragen. Nun müsste der Befehl allerdings so erweitert werden, dass wenn die Werte in C und D Größer gleich 25 sind eine 2 und bei Werten größer gleich 40 eine 3 eingetragen wird. Mein Freund der mir da normalerweise hilft ist zur zeit leider im Urlaub, darum hoffe ich dass mir jemand mit besseren Kenntnissen als den meinen aushelfen kann.

Nach Möglichkeit würde ich gerne auf Makros oder so verzichten und mit Befehlsverkettungen wir der bereits vorhandenen arbeiten.

MfG raster

Expertenantwort
von Oubyi, Community-Experte für Excel, 38

Ich zeige Dir das erstmal "klassisch", also so wie es meist in der Schule verlangt wird:

=WENN(UND($C1>=40;$D1>=40);3;WENN(UND($C1>=25;$D1>=25);2;WENN(UND($C1>=10;$D1>=10);1;0)))

(Achtung, die Reihenfolge von hoch nach niedrig ist hier wichtig)
und so, wie ich es machen würde:

=($C1>=10)*(D1>=10)+($C1>=25)*(D1>=25)+($C1>=40)*(D1>=40)

Falls Dich das verwirrt, vergiss es einfach oder frage nach, falls es Dich interessiert.

Klappt es?

Kommentar von raster280 ,

Bei der wie du sie nennst "Klassischen" Lösung denke ich komm ich von der Logik schon zurecht, ist im Endeffekt ja nicht sonderlich kompliziert, auch wenn mir jeder Ansatz gefehlt hat, wie die Strukturierung aussehen muss. Auf deinen Lösungsansatz wäre ich wohl nicht gekommen, auch wenn mir die Boolesche Algebra durchaus ein Begriff ist. Mit logischen Verknüpfungen an sich komm ich schon zurecht, allerdings arbeite ich eher mit Elektrobauteilen als mit Tabellen. Ich bedanke mich auf jeden fall für die zügige und kompetente Antwort.

Ach ja beide Ansätze funktionieren wie zu erwarten exakt so wie ich es haben wollte.

MfG raster

Kommentar von Iamiam ,

und wenn Du nicht 1, 2, 3 eintragen musst, sondern 5%, 12%, 25% (also was Krummes), dann
=Wahl(($C1>=10)*(D1>=10)+($C1>=25)*(D1>=25)+($C1>=40)*(D1>=40);5%;12%;25%)

ich vermeide nämlich verschachtelte Wenn-Formeln wenns geht, weil man da so leicht Klammerfehler produziert. Und das hier ist obendrein kürzer als 3 verschachtelte Wenn()

Kommentar von Oubyi ,

@lamiam:
DH!
Schöne Erweiterung.
Ich habe auch schon entdeckt, dass man mit dem eher unbekannten WAHL() sehr viel "anstellen" kann.

Kommentar von Oubyi ,

Freut mich, dass ich helfen konnte ☼
Mit solchen "Boolschen Tricks" (:o) kann man - wie zu sehen - manchmal Formeln wesentlich übersichtlicher gestalten.

Antwort
von Ortogonn, 10

Formalantwort (kann man hier bei GF eigentlich immer noch nur dann eine beste Antwort vergeben, wenn mind. 2 Antworten gegeben wurden?) Dann dies hier zum Ermöglichen desselben bei Oubyis Lösung  :)


Kommentar von Oubyi ,

Danke.
Ja, ist immer noch so, soweit ich weiß.

Keine passende Antwort gefunden?

Fragen Sie die Community