Frage von Jinjuriki, 136

Wie kann ich in Excel nur Stellen nach dem Komma addieren?

Ich habe vorerst diese Formel benutzt, "SUMME(A1:A10)-SUMMENPRODUKT(GANZZAHL(A1:A10))".

Gibt es dafür auch eine kürzere und übersichtlichere Formel?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 102

Es gibt eine recht kurze Formel, aber ob du sie als übersichtlicher empfindest, musst du beurteilen.

=SUMMENPRODUKT(REST(A1:A10;1))
Kommentar von dkilli ,

DH

Kommentar von Suboptimierer ,

Noch kürzer wäre 

=SUMME(REST(A1:A10;1))

Das müsstest du dann aber mit Strg + Shift + Enter abschließen.

Antwort
von dkilli, 67

Wenn du MS Office ab 2010 hast, so kannst du diese Formel verwenden:

=REST(AGGREGAT(9;6;A1:A10);1)

Aggregat funktioniert auch in LibreOffice!

Das hat den Vorteil, dass in der Reihe A Fehler vorhanden sein dürfen!

Die Formeln von Suboptimierer (so gut wie die sind) zeigen da einen Fehler an.

Siehe die Bilder

http://www.bilder-upload.eu/show.php?file=724d3c-1461503153.png

http://www.bilder-upload.eu/show.php?file=e21881-1461503355.png

Kommentar von Iamiam ,

ich denke, mit Aggregat() müssen wir alle noch ein bisschen üben!

Obige Formel gibt den Nachkommastellenanteil der Restesumme an, nicht die Summe aller Nachkommastellen!

Fehlertoleranz krieg ich nur so hin:

{=SUMME(WENNFEHLER(REST(A1:A10;1);0))}

und da Wennfehler offenbar nicht in die Matrixwirkung von Summenprodukt eingebaut wird, bringt es keinen zusätzlichen Vorteil, es müsste ebenfalls als Matrixformel eingegeben werden:

{=SUMMENPRODUKT(WENNFEHLER(REST(A1:A10;1);0)*1)}

Mit Aggregat kriege ich auch keine richtige Lösung, wenn ich schreibe:

=AGGREGAT(9;6;REST(A1:A10;1))

auch nicht, wenn ich es als {Formel} eingebe.

Kommentar von dkilli ,

hallo lamiam,

rechne mal alle Nachkommastellen zusammen. Leider ist auf dem Bild ein Fehler. In A4 muss 1245,123 stehen. Die 3 war abgeschnitten! Als Ergebnis kommt dann 0,825 heraus.

Deine Formel =AGGREGAT(9;6;REST(A1:A10;1)) ist falsch!
Mit AGGREGAT(9;6;F3:F7) wird die Summe von A3 bis A7 berechnet. Erst dann muss der Rest berechnet werden

Kommentar von Iamiam ,

Beispiel: 1,5; 2,2; 0,7: Restesumme: =1,4

Die Aggregatformel
=REST(AGGREGAT(9;6;A1:A10);1)  liefert aber 0,4, nämlich den Rest der -allerdings tatsächlich fehlertoleranten- Summe

Ich komme tatsächlich nur per Matrixformel auf ein fehlertolerantes Verfahren.

Kommentar von dkilli ,

Du hast recht. Die Formel mit Aggregat funktioniert nur wenn die Summe der Nachkommastellen kleiner als 1 ist. 

Deine beiden Formel funktionieren einwandfrei!

Dafür DH

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten