Wie kann ich in Excel zwei oder mehr Zellen mit einer Spalte vergleichen?

... komplette Frage anzeigen

3 Antworten

Nehmen wir an, dass die gesuchten Zahlen in Spalte B stehen. Ich verwende die Spalte C als Hilfsspalte.

Dann kommt in C1 folgende Formel:

=WENN(B1="";"";NICHT(ISTNV(VERGLEICH(B1;A:A;0))))

und diese Formel wird so weit wie nötig (oder ggf. weiter) nach unten "gezogen".

In Spalte B eingegebene Zahlen werden auf Vorhandensein geprüft, und leere Zellen ignoriert.

Um zu prüfen, ob alle nicht-leeren Werte in Spalte C WAHR sind, nimmst du den Ausdruck

UND(C:C)

z. B. in Spalte D1 die Formel

=UND(C:C)

Dann steht in D1 dann und nur dann "WAHR", wenn jede in Spalte B eingetragene Zahl auch in Spalte A vorkommt.

=SUMME(ZÄHLENWENN(A1:A100;{1;2;3}))

Die so ermittelte Summe muss der Anzahl der gesuchten Zahlen in den {} entsprechen, hier also 3. Dann sind alle Zahlen in der Spalte A1 : A100 enthalten.

Kommentar von nadinedh
04.12.2015, 13:06

Wie schreibe ich die geschwungenen Klammern? Ich versuche es dann gleich :-) Danke

0

=WENN((ZÄHLENWENN(A1:A10;1)>0)*(ZÄHLENWENN(A1:A10;3)>0)*(ZÄHLENWENN(A1:A10;4)>0);"Ja";"Nein")

Statt 1, 3 und 4 in der Formel kannst Du natürlich auch Bezüge zu Zellen nutzen, in denen die Zahlen stehen (z.B C1, D1, E1):

=WENN((ZÄHLENWENN(A1:A10;C1)>0)*(ZÄHLENWENN(A1:A10;D1)>0)*(ZÄHLENWENN(A1:A10;E1)>0);"Ja";"Nein")

Hilft Dir das?

Kommentar von Oubyi
04.12.2015, 14:33

P.S.:
Ninombres Formel ist allerdings schöner
(Hatte ich zu spät gesehen)

0

Was möchtest Du wissen?