Frage von nadinedh, 32

Wie kann ich in Excel zwei oder mehr Zellen mit einer Spalte vergleichen?

In der ersten Spalte (ca. 100 Werte) befinden sich dieverse Zahlen (1;2;3;5;8;...) ich möchte nun wissen, ob z.B. die Zahlen 1, 3 UND 4 dort vorhanden sind (also in diesem Bsp. nicht) oder z.B. die zahlen 1, 3 UND 8 dort vorhanden ist (also in diesem Bsp. ja). Und es darf nur wahr sein, wenn alle gesuchten Zahlen dort vorkommen. Hab ich das verständlich geschrieben? Vielen Dank, Nadine

Antwort
von PWolff, 28

Nehmen wir an, dass die gesuchten Zahlen in Spalte B stehen. Ich verwende die Spalte C als Hilfsspalte.

Dann kommt in C1 folgende Formel:

=WENN(B1="";"";NICHT(ISTNV(VERGLEICH(B1;A:A;0))))

und diese Formel wird so weit wie nötig (oder ggf. weiter) nach unten "gezogen".

In Spalte B eingegebene Zahlen werden auf Vorhandensein geprüft, und leere Zellen ignoriert.

Um zu prüfen, ob alle nicht-leeren Werte in Spalte C WAHR sind, nimmst du den Ausdruck

UND(C:C)

z. B. in Spalte D1 die Formel

=UND(C:C)

Dann steht in D1 dann und nur dann "WAHR", wenn jede in Spalte B eingetragene Zahl auch in Spalte A vorkommt.

Expertenantwort
von Oubyi, Community-Experte für Excel, 22

=WENN((ZÄHLENWENN(A1:A10;1)>0)*(ZÄHLENWENN(A1:A10;3)>0)*(ZÄHLENWENN(A1:A10;4)>0);"Ja";"Nein")

Statt 1, 3 und 4 in der Formel kannst Du natürlich auch Bezüge zu Zellen nutzen, in denen die Zahlen stehen (z.B C1, D1, E1):

=WENN((ZÄHLENWENN(A1:A10;C1)>0)*(ZÄHLENWENN(A1:A10;D1)>0)*(ZÄHLENWENN(A1:A10;E1)>0);"Ja";"Nein")

Hilft Dir das?

Kommentar von Oubyi ,

P.S.:
Ninombres Formel ist allerdings schöner
(Hatte ich zu spät gesehen)

Kommentar von Ninombre ,

Dafür lässt sich diese Variante mit Zellen flexibler handhaben: Man muss ja nicht immer in der Formel herumfummeln. In die Arraykonstanten bekomme (zumindest ich) keine Zellbezüge hin.

@Nadine: Hast jetzt drei Varianten und die freie Auswahl

Expertenantwort
von Ninombre, Community-Experte für Excel, 32

=SUMME(ZÄHLENWENN(A1:A100;{1;2;3}))

Die so ermittelte Summe muss der Anzahl der gesuchten Zahlen in den {} entsprechen, hier also 3. Dann sind alle Zahlen in der Spalte A1 : A100 enthalten.

Kommentar von nadinedh ,

Wie schreibe ich die geschwungenen Klammern? Ich versuche es dann gleich :-) Danke

Kommentar von Ninombre ,

Alt Gr + 7 bzw. 0
(Alt Gr ist meist rechts neben der Leertaste)

Kommentar von nadinedh ,

Danke :-) Ich habe es probiert, aber als Ergebnis bekomme ich nur, wie viele meiner "Soll-Zahlen" in der A-Spalte sind, nicht ob alle vorhanden sind oder nicht. Zur Not würde das gehen, besser wäre aber, wenn ich auf einen Blick erkennen kann, ob diese Kombination vorkommt oder eben nicht. Geht das auch? Vielen Dank schon mal :-)

Kommentar von Ninombre ,

Du kannst noch ein Wenn darum bauen. Allerdings fällt mir keine Möglichkeit ein, die Anzahl der gesuchten Zahlen direkt zu ermitteln, d.h. Du musst es manuell anpassen. Das wäre die Variante für 4 gesuchte Zahlen:
=WENN(SUMME(ZÄHLENWENN(A1:A100;{1;4;2;3}))=4;"Alle da";"Fehlt was")

wenn es 5 wäre, zum einen die fünfte noch in {} und auf =5 ändern.

Kommentar von nadinedh ,

Super, vielen, vielen Dank für die tolle und schnelle Hilfe!!! :-)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten