Frage von Nailoh, 60

Wie kann ich in Excel so sortieren das in Spalte b alle werte so umsortieren das sie neben dem identischem wert in spalte a stehen?

Hi!

Ich möchte das alle Werte mit übereinstimmenden Inhalt aus Spalte "B" auf der gleichen höhe wie in Spalte "A" sind, desweiteren sollen die Werte aus Spalte "C" weiterhin hinter dem Inhalt aus "B" stehen.

Sehr verwirrend, anbei sind zwei Bilder die die Situation einfach Darstellen

Expertenantwort
von DeeDee07, Community-Experte für Excel, 35

Füge zwischen Spalte A und B zwei neue Spalten ein. Was bisher in B und C war, ist jetzt in D und E.

Formel für B1: =A1 (und runterkopieren)

Formel für C1:
=INDEX(E:E;VERGLEICH(B1;D:D;0))
(ebenfalls runterkopieren)

Falls du die beiden Werte von A und B nicht doppelt brauchst, kannst du auch nur eine Spalte einfügen, die erste Formel weglassen und die zweite anpassen. Ggf. kannst du die "alten" unsortierten Spalten ausblenden.

Kommentar von Nailoh ,

Klappt einwandfrei danke!

Antwort
von gfntom, 38

Folgende Lösung funktioniert nur, wenn es zu jedem Wert in A genau einen dazugehörigen Wert in B gibt:

Sortiere zuerst nur Spalte A
Sortiere dann Spalte B&C gemeinsam, mit B als Sortierschlüssel

eventuell A unf B&C noch ausrichten.

Falls meine Prämissen nicht zutreffen, müsstest du erklären, wie du es dann haben willst. Vermutlich wirds dann aber keine "einfache" Lösung geben.


Expertenantwort
von Oubyi, Community-Experte für Excel, 38

Markiere mal den gesamten Bereich der Spalten B und C in dem die verteilten Daten sind.
Dann F5 drücken (Gehe zu...)
Inhalte... --> Leerzellen
OK.
Jetzt:
STRG & - (Minus) --> "Zellen löschen (nach oben verschieben)".
OK.

Jetzt hast Du dort alle in einem Block und kannst ihn auf die Höhe der A-Werte verschieben.
Fertig.

Klappt es?

Kommentar von Nailoh ,

nicht genau was ich wollte.

Ich drück mich mal anders aus.

Steht Kuchen in A3 und Kuchen in B7, soll er mir B7 und C7 auf B3 verschieben.

Kommentar von Nailoh ,

in meinem Fall sind es zwar Zahlenwerte und keine Wörter aber das dürft keinen unterschied machen

Kommentar von Oubyi ,

Dann sollte DeeDees Formel die Lösung für Dein Problem sein.
Oder?

Kommentar von Oubyi ,

P.S.:
(Vorausgesetzt "Kuchen" kommt in beiden Spalten nur einmal vor).
Falls Dich bei nicht vorhandensein von "Kuchen" in Spalte B bzw. D nach dem Einfügen der Zusatzspalten das #NV stört, kannst Du das so unterdrücken:
=WENNFEHLER(INDEX(E:E;VERGLEICH(B1;D:D;0));"")

Antwort
von MagicalMonday, 37

Klicke auf einen der Werte in Spalte B und wähle im Menü im Sortierfilter "Nach Größe sortieren (aufsteigend)." Anschließen markierst du die ganze Spalte A (Klick auf das A) und führst den gleichen Filter noch mal aus. Beim ersten Mal wird alles nach Spalte B sortiert, beim Zweiten nur Spalte A allein.

Jetzt musst du vielleicht noch einmalig etwas verschieben.

Kommentar von Nailoh ,

das Problem ist:

1. Das ich nicht schieben will da es eine wirklich lange liste werden kann 

2. Es können Werte die in A stehen in B nicht mehr vorhanden sind oder auch anders herum

Keine passende Antwort gefunden?

Fragen Sie die Community