Frage von iMPerFekTioN, 54

Wie kann ich in Excel mit der =RECHTS() Funktion die Nachkommastelle einer Währung anzeigen lassen?

Hallo Liebe Community,

jetzt frag ich auch endlich mal was zu Excel! Ich bin schier am verzweifeln!

Ich habe eine Tabelle mit den verschiedensten Werten, (Währungen € und $) So, jetzt möchte ich meine Zahlen aber "schöner" haben!

D.h. wenn die Nachkommastelle einer Zahl z.B. 29,37€ (hier also die 37) kleiner als 50 ist, soll die Ganzzahl genommen werden und mit 50 addiert werden.

Wenn die Zahl aber Größer als 50 ist, sollen 0,95 zu der Ganzzahl hinzugerechnet werden.

Beispielaufbau: A1 24,58€ A2 57,30€

Formel in B1= =WENN(RECHTS(A1;2)>50;GANZZAHL(A1)+0,95;GANZZAHL(A1)+0,50)

Das Problem ist nur, dass wenn ich bei Zelle A2, die Formel =RECHTS(A2;2) nutzen würde, ich die Zahl ,3 als Rückgabe bekomme. Die "0" wird hier nicht angenommen bzw mit ausgelesen.

Weiß hier jemand einen Rat?

Liebe Grüße,

iMPerFekTioN

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 26

Klappt es so besser?:

=WENN((A1-GANZZAHL(A1))*100>50;GANZZAHL(A1)+0,95;GANZZAHL(A1)+0,5)

Kommentar von surbahar53 ,

Statt A1-GANZZAHL(A1) könnte man auch REST(A1;1) verwenden

Kommentar von iMPerFekTioN ,

Ganzzahl ist hier aber genau das was ich brauche!

Super!

Das ich da nicht selber drauf gekommen bin =)
Danke dir Oubyi =)

Kommentar von Oubyi ,

Gern geschehen 😉

Kommentar von surbahar53 ,

Kein Problem, aber REST(A1;1) ist doch einfacher zu lesen als A1-GANZZAHL(A1). Man muss es auch nicht extra klammern.

Kommentar von Oubyi ,

DH!
Du hast Recht.
Merke ich mir fürs nächste Mal.

Kommentar von Iamiam ,

und ich warte jetzt nur noch drauf, dass die € als Zeichen drinstehen und das ganze ein Text variabler Länge ist... (und möglicherweise bleiben soll, weil danach gesucht werden muss ☹ )

Kommentar von Oubyi ,

Danke fürs

Kommentar von Iamiam ,

@ imperfektion: Sorry für den Kommentar, hab nicht auf den Namen geachtet, bei Dir weiß ich, dass Du sowas richtig formulierst!

Antwort
von daCypher, 21

Ich würde das nicht mit der Rechts-Funktion machen (die ist in erster Linie gut, um Wörter oder Sätze auseinanderzunehmen), sondern einfach die Zahl vor dem Komma abziehen.

=A1 - GANZZAHL(A1)

Da bleibt dann z.B. 0,58 oder 0,3 übrig und du kannst es ins Wenn einbauen.

=WENN(A1-GANZZAHL(A1) > 0,5; GANZZAHL(A1)+0,95; GANZZAHL(A1)+0,5)

Kommentar von iMPerFekTioN ,

Auch an dich vielen lieben Dank daCypher!

Deine und die Lösung von Oubyi sind ja eigentlich die gleichen =)

Nur leider war er ein paar Sekunden schneller :)
Trotzdem, vielen vielen Dank!

Kommentar von daCypher ,

Bitteschön :)

Ja, diesmal hat Oubyi das Wettrennen gewonnen :-D

Keine passende Antwort gefunden?

Fragen Sie die Community