Wie kann ich Hotelzimmer-Shares in einer Exceltabelle finden?

... komplette Frage anzeigen

2 Antworten

Es geht ja hauptsächlich darum, die Datumsüberschneidung zu erkennen.

Eine Überschneidung liegt vor, wenn das Startdatum (oder Enddatum) eines Aufenthalts im Zeitraum eines anderen liegt.

Füge in der Spalte K folgende Formel ein und zieh sie herunter:

=SUMMENPRODUKT(($I2>=$I$2:$I$100)*($I2<=$J$2:$J$100)*($B2=$B$2:$B$100))>1

Willst du das Pendant angezeigt bekommen, musst du das Endedatum in den Aufenthaltsdauern auf gleiche Weise suchen.

Eine bedingte Formatierung würde auf ähnliche Weise mit der Formel funktionieren.

Es werden aber nur die Überschneidungen angezeigt, nicht welcher Aufenthalt sich genau mit welchem anderen überschneidet.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von frhi2015
03.11.2015, 15:40

Vielen Dank für die Antwort. Es klappt allerdings noch nicht ganz. Mit der Sumproduct - Formel kenne ich mich aber auch nicht aus. Ich habe zudem eine englische Office-Version. Kann ich dir etwas schicken? Die Formel hat nur vier Zeilen mit TRUE markiert. Alle anderen stehen auf FALSE, obwohl noch einige ganz eindeutige Shares dabei sind (gleiches An- und Abreisedatum).

Danke sehr.

0

Warum wird diese mit jedem Monat länger? Habt Ihr nicht für jeden Monat ein Buchungsblatt in einen Jahresarbeitsmappe?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von frhi2015
03.11.2015, 12:09

Danke für die schnelle Reaktion. Es gibt nur eine grosse Liste. Diese Liste ist die Quelle für verschiedene Pivottabellen. Durch das identifizieren der Shares, möchte ich diese Tabelle aufräumen. Shares sollen nämlich nicht als zwei Reservierungen gezählt werden, sondern nur als eine.

0