Frage von tigerduck0915, 101

Wie kann ich einen Textteil, der in der ersten Zelle steht in einer zweite Zelle suchen und den gesuchten Teil in einer neuen Zelle ausgeben (mit Excel Formel)?

Hallo, Und zwar möchte ich den Inhalt einer Zelle in einer anderen Zelle suchen, die aber mehr Buchstaben besitzt, als die Zelle, in der der gesuchte Inhalt steht. Der gesuchte Inhalt der Zelle soll dann von Excel in einer neuen Zelle ausgegeben warden.

Beispiel:

Textfeld:

Messe 123 Frank Mustermann

Lise Müller Besuch Messebesuch XYZ

Frank Schulz Besuch Messe ZZZ

Suchkriterium 1:

Lise Müller

Frank Mustermann

Lotta Meier

Britta Schulze

Jetzt soll Excel in dem Textfeld nach allen Namen suchen und in der Zelle neben dem Text den Namen ausgeben, der in der entsprechenden Zelle gefunden wurde.

Habt ihr eine Idee?

Antwort
von Ortogonn, 101

Bei herber im Forum bin ich schließlich fündig geworden:

Du hast keine Angaben gemacht, welche Zellen du in deiner Tabelle nutzt. Daher hab ich folgende genommen:

  • zu durchsuchende Zellen stehen in Spalte A (A1, A2, A3, ..., A99)
  • Suchkriterien (Wortliste) stehen in E4, E5, E6, E7

diese Bezüge musst du dann auf deine Tabelle anpassen.

Formel in B1:

=WENNFEHLER(INDEX(E$4:E$7;AGGREGAT(15;6;ZEILE(A$1:A$99)/VERGLEICH("*"&E$4:E$7&"*";A1;)/(E$4:E$7<>"");1));"")

und nach unten kopieren

Kommentar von DeeDee07 ,

DH! Aggregat kannte ich bei Excel bisher noch gar nicht.

Kommentar von Oubyi ,

Kannte ich auch noch nicht.
Und nach kurzem Betrachten des Assistenten tue ich mir das auch nicht an (:o)

Kommentar von Ortogonn ,

Kannte ich ebenfalls nicht. Die Frage bei herber ist identisch, nur das Auffspüren ist mein Verdienst ;)

Und auch ich glaub nicht, dass Aggregat Bestandteil meiner täglich genutzten Fuktionen wird :D

Allerdings werde ich sie im Auge behalten.

Hier mal ein netter text dazu:

http://www.office2010-blog.de/de/start/excel/aggregat-neue-maechtige-funktion-in...

Kommentar von tigerduck0915 ,

Vielen Dank Ortogonn für's aufspüren der Formel (Ich hab's auch versucht was im Internet zu finden, das war aber erfolglos). Die Formel kannte ich auch noch nicht. Funktioniert auf dem Rechner mit Office 2010 wunderbar (auch bei größerer Datenmenge) :-)

Kommentar von Ortogonn ,

Zuerst habe ich ein paar Dinge selbst probiert, aber bin irgendwie nicht zum gewünschten Ergebnis gekommen.

Es hat mich aber gereizt.

Dann hab ich eine ganze Weile gesucht. Die Suchbegriffe weiß ich nicht mehr, aber ich musste mich rantasten. Das "offensichtliche", was mir als Begrifflichkeiten zuerst einfiel, hat nicht zum Ziel geführt.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten