Frage von FotoLA2HH, 35

Wie kann ich eine Wenn-Anweisung in Excel schreiben die eine Zelle nach einem bestimmten Wort durchsucht und dafür in einer anderen Zelle dieses Wort ausgibt?

Expertenantwort
von Ninombre, Community-Experte für Excel, 14

Vielleicht ist es nur missverständlich formuliert, aber sicherheitshalber : mit Formeln wird immer nur die Zelle geändert, in der sie steht. Man kann nicht in andere Zellen hinein schreiben. Ansonsten hat oubyi ja die passende Lösung beschrieben 

Expertenantwort
von Oubyi, Community-Experte für Excel, 23

=WENN(ISTFEHL(FINDEN("Wort";A1));"";"Wort")

Oder, wenn das "Wort" z.B. in A2 steht:

=WENN(ISTFEHL(FINDEN(A2;A1));"";A2)

Kommentar von FotoLA2HH ,

Sind die Anführungszeichen wichtig für die Syntax? Wenn ich die Formel kopiere und A1 gegen das zu durchsuchende Feld ersetze bzw Wort gegen den Suchbegriff austausche, dann bleibt nur die Formel dort stehen

Kommentar von Ghanasoccer ,

Alles was Oubyi dick markiert hat ist in der Formel von Bedeutung.

=WENN(ISTFEHL(FINDEN("Wort";A1));"";"Wort")
=WENN(ISTFEHL(FINDEN(A2;A1));"";A2)
Kommentar von Oubyi ,

dann bleibt nur die Formel dort stehen

Ja, die " " sind wichtig.
Entweder Du hast das "=" am Anfang vergessen,
oder die Zelle, in die Du die Formel schreibst ist als Text formatiert.
oder Du hast "Formeln/ Formelüberwachung/ Formel anzeigen" aktiviert.
Trifft eines davon zu?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten