Frage von PinoGrigio, 54

Wie kann ich diese Zellen unterschiedlich formatieren?

Hallo,

wie kann ich diese Zellen unterschiedlich formatieren?

  1. Zellart: ='[Datei 2015.xlsx]Blatt01'!$D10
  2. Zellart: =H12 ?

d.h. in einer Zelle steht ein Bezug in eine andere Datei und in der anderen lediglich ein Bezug in eine andere Zelle.

Was ich schon versucht habe:

1) =LINKS(Text;Anzahl Zeichen), geht nicht, da man nur auf das Erg. der Formel zugreifen kann und nicht auf die Formel selbst.

2) bed. Format mit Text enthält "xlsx", jedoch gleiche Problematik Formel/Wert.

Weiß jemand noch, wie man die Zellen unterschiedlich einfärben kann?

LG PG

Expertenantwort
von DeeDee07, Community-Experte für Excel, 32

Falls du Excel2013 oder neuer benutzt, kannst du möglicherweise die Funktionen LÄNGE iVm FORMELTEXT verwenden. https://support.office.com/de-de/article/FORMELTEXT-Funktion-0a786771-54fd-4ae2-...

Ich kann es hier nicht testen, da keine entsprechende Excel-Version vorhanden.

Für ältere Versionen könnte man sich vielleicht mit der Funktion ZELLE und dem Infotyp "Dateiname" was zusammenbasteln.

Kommentar von PinoGrigio ,

Danke, das war's!

Antwort
von Jackie251, 37

Welche Excelversion benutzt du denn?

bei mir funktioniert die bedingte Formatierung mit

=LINKS(FORMELTEXT(A6);3)="='["

problemlos. Allerdings gibt es Formeltext nicht in jeder Excelversion

Kommentar von PinoGrigio ,

Hallo Jackie, 

Danke, das hat geholfen. 

Ich hab's jetzt so gelöst: 

=WENNFEHLER(SUCHEN("xlsx";FORMELTEXT($D4));0)>0

LG PG

Kommentar von Iamiam ,

mit

=LINKS(FORMELTEXT(A6);3)="='["
muss man sehr aufpassen, da die Datei von xl unterschiedlich dargestellt wird, je nachdem, ob es ein Blatt-interner Verweis, ein Blattexterner aber Dateiinterner Verweis oder ein Dateiexterner Verweis auf eine geöffnete oder auf eine geschlossene Datei ist. Beispiel:Typen Verweisformeln
selbes Blatt:    =B61
selbe Datei:     =Tabelle2!B61
and. off.Datei: =[VTabGes.xls]VTab1!$B$61 
geschl. Datei: ='H:\DALLI[VTabGes.xls]VTab1'!$B$61

Die Suche nach "[" oder nach "]" ist wohl das einzig sichere bei Dateiexternen Verweisen! (beachte: es kann auch .xls-Dateien, xlsm-Dateien, .csv-Dateien etc etc geben!

Kommentar von Iamiam ,

=Formeltext kannte ich übrigens auch noch nicht, ich hab das immer mit wahlweise =Zelle("Dateiname";A1) gemacht oder mit =Zelle("Adresse";A1) (oder komplizierten Teilstrings davon),

im Übrigen hab ich mir erst vor einigen Monaten eine Makroformel analog Formeltext in zwei Versionen gemacht (engl. und deutsch) gemacht, ich brauche sie also in Zukunft nur noch zum Übersetzen von engl. Formeln ins deutsche und umgekehrt.

Ist nicht das erste mal, dass xl die Formeln nachliefert, die ich zwischenzeitlich in VBA programmiert hab! (bei convert gabs sogar einen Namenskonflikt!).
Zeigt mir zumindest, dass meine xl-Bedürfnisse nicht ganz aus der Welt sind...

Kommentar von Jackie251 ,

Ich muss mich endlich auch mal näher mit VBA beschäftigen !

Kommentar von Iamiam ,

ist aber eine Riesen-Zeitsparkasse mit geringer Verzinsung und hohen Inflationsverlusten! Aber spannend!

Keine passende Antwort gefunden?

Fragen Sie die Community