Frage von xDeron, 38

Wie kann ich den Fehler beheben (siehe Beschreibung!)?

[19:47:31 ERROR]: Could not load 'plugins/LobbySystem.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/ls/main/Main : Unsupported major.minor version 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [minecraft_server.jar:git-Spigot-b73910a-726656b] at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [minecraft_server.jar:git-Spigot-b73910a-726656b] at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [minecraft_server.jar:git-Spigot-b73910a-726656b] at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [minecraft_server.jar:git-Spigot-b73910a-726656b] at java.lang.Thread.run(Unknown Source) [?:1.7.0_10] Caused by: java.lang.UnsupportedClassVersionError: de/ls/main/Main : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_10] at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_10] at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_10] at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_10] at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_10] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_10] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_10] at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_10] at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_10] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_10] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_10] at java.lang.Class.forName0(Native Method) ~[?:1.7.0_10] at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_10] at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[minecraft_server.jar:git-Spigot-b73910a-726656b] ... 6 more

Programmierprogramm: Eclipse Javaversion: 1.8 Pluginjavaversion: 1.8 Verwendete API für das Plugin: Bukkit

Antwort
von Belaro, 24
Unsupported major.minor version 52.0

Habe kurz im Internet nachgeschaut und den Anschein nach ist das der Grund. Du hast irgendein Plugin drinnen, welches Java 8 nicht unterstützt. Versuche es mit Java 7 oder 6 zu kompilieren.

Quelle: http://stackoverflow.com/questions/22489398/unsupported-major-minor-version-52-0

Kommentar von xDeron ,

Was ist kompilieren?

Kommentar von xDeron ,

Ah weiß es jetzt aber wie kompiliere ich das Plugin zur Version 1.7??

Kommentar von xDeron ,

Habs herausgefunden xD

Keine passende Antwort gefunden?

Fragen Sie die Community