Frage von calgia, 38

Wie kann ich das in EXCL mit der WENN Formel erreichen?

Hallo zusammen

Ich habe eine Frage betreffend der Wenn Formel in Excel.

Bitte schaut euch hierzu die Fotos an, welche ich hier beigefügt habe.

Zelle D28 ist mit Zelle E28 verbunden, runter bis Zeile 35 und Zelle B37 ist bis E37 und das herunter bis in die Zelle 44 ist verbunden. Kann ich einstellen, dass er in der Zelle B37:e35 (verbundene Zellen) anzeigt, Windows 10 ist um [Inhalt Zelle D28 (ff) ] schneller als Windows 7, also wenn der Wert in C28 grösser ist als in B28 und Windows 7 ist um [Inhalt Zelle D28 (ff) schneller als Windows 10, also wenn der Wert in B28 grösser ist als in C28.

Zum Verständnis:

Foto 1 Zelle E116 =MITTELWERT(Testmessung 1: Testmessung 3) also =MITTELWERT(B16:D16)

Foto 2 Zelle 2 und fort folgende bis Zelle 35 =WENN(B28<C28;C28-B28;B28-C28)

Besten Dank für eure Hilfe!

Freundliche Grüsse

calgia

Expertenantwort
von Ninombre, Community-Experte für Excel, 10

=WENN(ABS(B28-C28)<=B28/100;"Gleiche Ergebnisse";INDEX(B$27:C$27;;VERGLEICH(MIN(B28;C28);B28:C28;0))&" ist um "&TEXT(ABS(B28-C28);"[h]:mm:ss")&" schneller")

Ich würde unterstellen, dass ein zeitlicher Unterschied von 1% als gleiches Ergebnis zählt. Wenn es wirklich nur identische Zeiten sein sollen, dann

=WENN(B28=C28;"Gleiche Ergebnisse";INDEX(B$27:C$27;;VERGLEICH(MIN(B28;C28);B28:C28;0))&" ist um "&TEXT(ABS(B28-C28);"[h]:mm:ss")&" schneller")

Antwort
von offeltoffel, 26

Vorschlag:

=WENN(C2<B2;VERKETTEN("Windows 10 ist um ";B2-C2;" schneller als Windows 7");VERKETTEN("Windows 7 ist um "; C2-B2; " schneller als Windows 10"))

Deckt aber nicht den Fall ab, dass beide gleich sind. Die Umrechnung der Zeit-Formatierung in eine Kommazahl müsstest du auch noch basteln.

Antwort
von AnonYmus19941, 25

in B37:

="Windows " & WENN(B28>C28;"7";"10") & " ist um " & D28 & " schneller als Windows " & WENN(B28<C28;"7";"10")

Das sollte funktionieren (ich probier es gleich aus), ansonsten nur den ersten WENN-Teil, wobei du die sieben und die 10 mit dem jeweiligen Text ersetzt.

Kommentar von AnonYmus19941 ,

Alternativ kannst du auch einfach in Zelle D28 ff. nur die Differenz nehmen, dann kommen da u. U. negative Werte raus, aber das macht ja auch nichts ...

Kommentar von AnonYmus19941 ,

Funktioniert bei mir.

Kommentar von calgia ,

super danke jetzt zeigt er das ganze in 0.000000 an kann man ihm das auch lernen dass er das in 00:00:00 anzeigt wie oben?

Kommentar von offeltoffel ,

Die 00:00:00 ist ja nur eine Anzeige, eine Formatierung. Intern rechnet Excel immer mit den entsprechenden Kommazahlen.

Einfacher wäre es, wenn du generell auf diese Schreibweise umstellst. Am einfachsten geht das über eine Zelle für die Stunden, eine für die Minuten und eine für die Sekunden. Daneben machst du eine Zelle, in die er es in ganze Stunden umrechnet.

2h 24min 37sec = 2 + 24/60 + 37/3600 = 2,410278h

Kommentar von calgia ,

ich würde lieber die andere anzeige verwenden. gibt es dafür auch eine Lösung?

Kommentar von offeltoffel ,

Wäre mir nicht bekannt. Du erzeugst ja einen Text-String, indem du mehrere Elemente verkettest (Funktion "VERKETTEN"). Er wandelt daher jede Zahl in einen Text-String um. Ich kenne keine Option in Excel, die dabei auch gleich eine Formatierung wählt. Du kannst eine Zelle ja nur gesamtheitlich formatieren, also dürfte das schwer werden.

Was funktioniert ist, dass du es doch nicht über 3 verbundene Zellen löst, sondern über drei einzelne.

B37: "Windows 7 ist um ", C37: "00:41:37", D37 " Zeiteinheiten schneller".

Dann kannst du C37 so formatieren, wie du das möchtest.

Kommentar von Oubyi ,

Ich misch mich mal ein:
Mit dieser erweiterten Formel von offelfoffel:

="Windows "&WENN(B28>C28;"7";"10")&" ist um "&TEXT(ABS(C28-B28);"hh:mm:ss")&" schneller als Windows "&WENN(B28<C28;"7";"10")

wird der Wert in Stunden, Minuten, Sekunden angezeigt.

Klappt es?

Kommentar von calgia ,

jaaa erstaulicherweise schon.

Kommentar von AnonYmus19941 ,

Folgende Formel (mit gerade einmal 346 Zeichen) wandelt einen Wert in Zelle G5, der dort in Tagen drinnen steht (Standard bei Excel, auch wenn es anders angezeigt wird; dort steht z. B. 0,22 für 5 Stunden), in HH:MM:SS um. Wenn du die Zelle entsprechend anpasst, kannst du sie benutzen. Ob du sie wirklich einsetzen willst, ist dir überlassen ... ;-)

=RUNDEN(UMWANDELN(G5;"day";"hr");0) & ":" & RUNDEN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn");0) & ":" & RUNDEN(UMWANDELN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn")-RUNDEN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn");0);"mn";"sec");0)

Keine passende Antwort gefunden?

Fragen Sie die Community