Frage von skater371, 42

wie kann ich bei sverweis die ausgabe definieren?

ich gebe in der spalte G aus ob die ip Adresse in beiden Tabellen vorhanden ist (SVERWEIS) jedoch steht da die IP Adresse und ich hätte lieber den Drucker Namen der in spalte B steht wie geht das?

Antwort
von Mojoi, 26

Wenn der Druckername hinter der Spalte G steht (z,B. in H), geht das.

Der Suchbereich kuss dann G und H umfassen und der Rückgabewert muss Spalte 2 sein.

Expertenantwort
von Oubyi, Community-Experte für Excel, 11

Wenn Deine Formel schon FAST funktioniert, dann zeige sie uns doch mal.
Das macht es wesentlich einfacher Dir zu helfen.

Antwort
von augsburgchris, 14

Für die Frage, ob eine Eingabe in 2 Tabellen vorhanden ist, ist SVERWEIS die denkbar schlechteste Formel. 

Du generierst hier mit voller Absicht Fehlerwerte, was unheimlich auf die Laufzeit gehen kann.

Verwende doch hier lieber ZÄHLENWENN. 


Ist die Eingabe in B1 in Spalte A vorhanden?

=WENN(ZÄHLENWENN(A:A;B1)>0;"ist da";ist nicht da")

Das ganze kannst du runterziehen und so jede Eingabe in Spalte B abfragen

SVERWEIS ist KEIN Allheilmittel.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten