Frage von KnorxyThieus, 68

Wie kann ich bei MuLab (MIDI-Software) die Soundverzögerung zwischen Keyboard und Lautsprecher verkleinern/beheben?

Hallo,

ich bin auf diesem Gebiet ein absoluter Noob und schon froh, dass ich überhaupt etwas hören kann :)

Jeder Ton ist erst ca. 1 Sekunde nach Anschlag der Taste auf dem Keyboard ODER Benutzen des virtuellen Keyboards in MuLab aus den externen Lautsprechern zu hören, Windows-Sounds dagegen "pünktlich".

Ich hatte schon einmal ähnliche Probleme und dort Abhilfe geschaffen, indem ich die Audiofrequenz weitmöglichst verkleinerte. Das habe ich jetzt hier auch schon getan, sowohl im MuLab-Audio-Setup als auch in den Windows-Audioeinstellungen, aber die Audioverzögerung bleibt bestehen.

Die Lautsprecher sind über den Kopfhörerausgang am Laptop (Medion Akoya, i5 2,8 GHz, 6 GB RAM, CPU-Auslastung ist aber immer kleiner 10%) angeschlossen, Dolby Digital ist aus, Keyboard (Roland Digital Piano RP301R) via USB verbunden.

Was kann ich noch tun? :-(

Mit freundlichen Grüßen,
KnorxThieus (♂)

Antwort
von friederapitz, 30

Hatte das selbe Problem, einfach mal die AudioTreiber wechseln. ASIO ist immer die beste Wahl.

Kommentar von KnorxyThieus ,

Danke, ich bin auf anderen Rat hier schon auf Asio4all umgestiegen, aber eine gewisse Latenz existiert trotz kleinster Werte immer noch ... :/

Antwort
von Kiboman, 53

asio4all

oder ein vernünftiges asio fähiges audio interface

Kommentar von KnorxyThieus ,

Sorry, beim Thema MIDI und Mix-Softwares und Audio und so fang ich echt von null an ...

Von meinem Desktop-PC aus lief das ganze mit weitaus geringerer Latenz. Ich habe Asio4all jetzt mal installiert und tatsächlich geschafft einzurichten!
Die Puffergröße habe ich auf Minimum gestellt, der Latenzausgleich schien mir keine Wirkung zu haben und der Buffer Offset ebenfalls nicht.
Dennoch ist die Latenz noch deutlich spürbar, wie kann sie noch weiter verkleinern? In den MuLab-Einstellungen geht die Frequenz leider nicht kleiner als 110000 Hz.

Kommentar von Kiboman ,

hast du denn im programm auch den asio4all treiber als audio gerät ausgewählt, oder auf windows audio gelassen?

wenn die verzögerung spürbar ist kannst du es verfolgen wo sie auftritt.

im programm müsste die ja der midi input an gezeigt werden,

ist die verzögerung zwischen input und output

oder zwischen output und hören.

abhilfe schafft auf jedenfall ein audio Interface, kleine liegen rund bei 60 - 80 euro

Kommentar von KnorxyThieus ,

Nein, unter MuLab im Audiosetup ist der Asio-Treiber angewählt.

Das Problem tritt auch auf, wenn ich mit der Maus am Laptop einen Sound abspielen will ...
Was kann ich kostenlos verbessern? Mein Laptop ist eigentlich gerade erst 2 Monate alt.

Kommentar von Kiboman ,

was benutzt du zur klang erzeugung?

eine vernünftige vsti oder microsofts wavetable?

es gibt freie vsti einfach mal teszen

Kommentar von Kiboman ,

als letztes angebot hab ich nur noch skype und TeamViewer,

sonst weiss ich grade aus dem kopf ohne was zu sehen auch nicht weiter.

Kommentar von KnorxyThieus ,

Wie lese ich das aus?

Keine passende Antwort gefunden?

Fragen Sie die Community