Frage von FranzAtGaming, 74

Wie kann ich bei Excel einer Summe sagen, dass sie nach dem gleichen Muster für die nächsten 100 Spalten rechnen soll?

Ich möchte einfach, dass ich nicht manuel die nächsten 100 Zahlen nach diesem Muster eingeben muss.

Ich suche also nach einer Methode um schnell +B83+B93...+B203" in die Formel einzu geben.

In dem Bild wird das eindeutig was ich meine und ich glaube dass das sehr einfach ist.

VIelen Dank!

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 50
=SUMMENPRODUKT(B:B*(REST(ZEILE(B:B);10)=3)*(ZEILE(B:B)>=13)*(ZEILE(B:B)<=203))
Kommentar von FranzAtGaming ,

So wie das da steht kommt der Fehler "Wert"

Kommentar von Suboptimierer ,

Bei mir nicht. Hast du die Formel in eine Zelle von Spalte B geschrieben? Stehen in Spalte B nichtnumerische Werte?
Das geht dann auf diese Weise nicht.

Kommentar von Oubyi ,

So wie das da steht kommt der Fehler "Wert"

Das wird daran liegen, das irgendwo in dem Bereich Text in einer Zelle steht, statt einer Zahl. Kannst Du das beheben? Sonst wird es schwieriger mit der Formel.

Kommentar von Oubyi ,

Falls sich Text nicht vermeiden lässt, funktioniert wohl die folgende Formel, die allerdings von der Performance her etwas langsam sein kann, da es eine "echte" Matrixformel ist:

{=SUMME(WENN(REST(ZEILE(B13:B1000)-3;10)=0;B13:B1000))}

**ACHTUNG!** Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

Kommentar von Suboptimierer ,

Danke! Du machst es mal wieder rund.

Ich hatte es sogar genauso probiert, aber da ich es nicht als Matrixformel abgeschickt habe, wunderte ich mich nur, weshalb es nicht funktioniert. Gerne hätte ich genau diesen Tipp gegeben.

Super!

Expertenantwort
von Ninombre, Community-Experte für Excel, 37

=SUMMENPRODUKT((REST(ZEILE(B13:B203)-3;10)=0)*(B13:B203))

Kommentar von Oubyi ,

DH!
Genau die gleiche Formel habe ich mir gerade auch zusammengebastelt (ohne zu spicken ).

Kommentar von Ninombre ,

soso ;-) aber hoffentlich hast Du das mit dem Rest cleverer gelöst als ich... statt rest(...)-3=0 kann man ja auch direkt rest(..)=3 nehmen wie Suboptimierer es gemacht hat.

Kommentar von Suboptimierer ,

Ist doch gehupft wie gesprungen ;)

Antwort
von Berny96, 45

Lästig:

=B13+B14+B15+B16+B17+B18+B19

Praktisch:

=SUMME(B13:B19)
Kommentar von FranzAtGaming ,

Es soll nicht einfach die nächste Spalte Summiert werden sondern nur die Spalten im Abstand von 10. Also B83+B93+B103...

Kommentar von Berny96 ,

Oh je, falsch verstanden. @Suboptimierer hat da eine sehr schöne Lösung. 

Expertenantwort
von Iamiam, Community-Experte für Excel, 50

ist auch eine Schülerfrage, die in ein Schüler-/Hausaufgaben-Forum gehört!

Formel einfach nach rechts kopieren.

Kommentar von FranzAtGaming ,

Erstmal vielen Dank für die schnelle Antwort. Was meinst du mit nach rechts Kopieren?

Kommentar von Iamiam ,

Falls das so gemeint war, wie ich es ursprünglich interpretiert hab:  Summen-Zelle markieren, dann in der Umrandung rechts unten auf das schwarze "Ausfüllkästchen"(heißt so) klicken (linke Maustaste) und mit gedrückter Taste nach rechts "ziehen" (Ausdruck wird oft so verwendet), das kopiert die Formel nach rechts in alle überstrichenen Spalten.

Kommentar von DeeDee07 ,

So trivial finde ich die Frage nicht. Allerdings hat der Fragesteller - wie so oft - wohl Spalten und Zeilen verwechselt. Da ist es kein Wunder, dass man sie auch anders verstehen kann.

Kommentar von Iamiam ,

kann sein, bin mir aber noch gar nicht so sicher!

Keine passende Antwort gefunden?

Fragen Sie die Community