Frage von PatPat1992, 106

Wie kann ich bei Excel bei SUMMEWENNS kriterium A oder B auswählen?

Folgendes muss ich in einer Exceltabelle machen: Welcher Gesamtumsatz wurde erzielt, falls folgende Rahmenbedingungen zu gelten haben:
o Kategorie „Obst/Gemüse“ oder „Fleisch/Geflügel“,
o Verschifft nach „Deutschland“ oder Großbritannien und o Umsatz >= 50,- € und <= 150,- €, d.h. Umsatz zwischen 50,- und 150,- €.

Nun habe ich im Internet gelesen, dass man mit einem "+" zwischen Kriterium a oder b auswählen kann aber ich komme einfach nicht auf die Formel, bzw setze ich es immer falsch ein und es kommt 0 raus (weil Excel denkt das es "Obst/Gemüse" und "Fleisch/Gefügel" ist.

Schon mal vielen dank für die Hilfe

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 82

Die Bedingungen in SUMMEWENNS werden und-verknüpft. Mit ODER-Verknüpfungen in SUMMEWENNS bin ich gerade überfordert.

Du könntest dir aber die Funktion SUMMENPRODUKT zur Hand nehmen:

=SUMMENPRODUKT(((A:A="Obst/Gemüse")+(A:A="Fleisch/Geflügel"))*((B:B="DE")+(B:B="GB"))*(C:C>=50)*(C:C<=150)*C:C)
Kommentar von Oubyi ,

Mit ODER-Verknüpfungen in SUMMEWENNS bin ich gerade überfordert

Einfache mehrere SUMMEWENNS-Funktionen addieren.
Aber schön finde ich SUMMEWENNS trotzdem nicht, meide diese Funktion und lösen so etwas auch immer mit SUMMENPRODUKT.

Kommentar von Suboptimierer ,

Das Problem ist die Anzahl an Kombinationenen. Es gibt 4 UND-Glieder, zwei davon bestehen aus ODER-Verknüpfungen. 

Es entstünden 4 SUMMEWENNS:

  • Obst, DE (, >=50, <= 150)
  • Obst, BE (,...)
  • Fleisch, DE (,...)
  • Fleisch, BE (,...)

Diese vier Fälle könnte man natürlich addieren, aber ich denke nicht, dass das das Ziel einer Schulaufgabe sein kann. Es sei denn, man will den Schülern zeigen, wie schön komfortabel SUMMENPRODUKT ist.

Expertenantwort
von DeeDee07, Community-Experte für Excel, 70

Muss es Summewenns sein?

Ich würde es so machen

=SUMMENPRODUKT((ODER(A2:A99="Obst/Gemüse";A2:A99="Fleisch/Geflügel"))*(ODER(B2:B99="Deutschland";B2:B99="Großbritannien"))*(UND(C2:C99>=50;C2:C99<=150))*(C2:C99))

(ungetestet)

Kommentar von PatPat1992 ,

=SUMMENPRODUKT((ODER(B:B="Obst/Gemüse";B:B="Fleisch/Geflügel"))*(ODER(G:G="Deutschland";G:G="Großbritannien"))*(UND(P2:P2156>=50;P2:P2156<=150))*(P2:P2156))

So habe ich es nun eingetippt aber am Ende kommt 0 raus (0 ist die falsche Lösung). 

Kommentar von DeeDee07 ,

Summenprodukt ist per Definition eine Matrixformel. Die Matrizen müssen dabei alle gleich groß sein. Du solltest also nicht ganze Spalten (B:B usw.) und begrenzte Bereiche (P2:P2156) zusammen verwenden.

Zum Testen, wo der Fehler liegt, kannst du die Formelauswertung starten. Dabei würde ich allerdings nur kleine Bereiche in der Formel auswählen, da die Ergebnisse sonst zu unübersichtlich sein werden.

Funktioniert Suboptimierers Formel? Beide sind sehr ähnlich, nur dass er die ODER und UND Verknüpfungen mit + und * umgesetzt hat.

Kommentar von augsburgchris ,

Du kannst keine Oder Beziehung in einer Arrayformel verwenden. Wenn dann musst du mit + und * arbeiten.

Kommentar von DeeDee07 ,

DH! Ich war mir sehr sicher, dass ich es früher mal erfolgreich mit ODER verwendet habe, beim Schnelltest ging es aber tatsächlich nicht, wobei ich das ein wenig pingelig von Excel finde. Danke für den Hinweis, chris!

(Das kommt halt davon, wenn man die Formel nicht testet)

Kommentar von augsburgchris ,

=SUMMENPRODUKT(((B:B="Obst/Gemüse")+(B:B="Fleisch/Geflügel"))*((G:G="Deutschland")+(G:G="Großbritannien"))*(P2:P2156>=50)*(P2:P2156<=150)*(P2:P2156))

Kommentar von PatPat1992 ,

Das hat geklappt, musste nur die B:B und G:G zu B2:B2156 und G2:G2156 umtauschen. Unendlich mal danke :) 

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten