Frage von Problem1993, 29

Wie kann ich bei Excel, bei einer Tabelle mit verschiedenen Zahlen die erste Zahl, falls sie 0 ist durch 1 ersetzen?

Expertenantwort
von DeeDee07, Community-Experte für Excel, 20

=WENN(LINKS(A1;1)="0";"1"&TEIL(A1;2;99);A1)

Kommentar von Problem1993 ,

Danke hat Super funktioniert

MFG

Kommentar von Iamiam ,

@Problem: Immer unterscheiden, Deine Nummern sind keine Zahlen, sondern Ziffern als Text! Sonst käme bei der ersten -1333 raus!

Expertenantwort
von Ninombre, Community-Experte für Excel, 14

Wenn immer eine 1 am Anfang stehen soll, könnte man die Wenn Abfrage sparen
=1&RECHTS(A1;LÄNGE(A1)-1) oder noch übersichtlicher, wenn die Länge immer gleich ist
=1&RECHTS(A1;8)

Antwort
von simonxority, 28

Meinst du, dass du mit der "Wenn"- Funktion arbeiten willst?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten