Frage von MCMeister, 76

Wie kann ich bei einem Minecraft Crash Report herausfinden, welche Mods nicht miteinander kompatibel sind?

Ich installiere mir ab und zu mal ein paar neue Mods für Minecraft (1.7.10) und nicht immer funktioniert jeder Mod. Nur würde ich wenn es sich lohnt für einen neuen Mod auch einen alten deinstallieren der nicht kopatibel ist. Nur sind die Crash Report für mich nicht wirklich übersichtlich genug, herauszufinden welcher Mod jetzt die Probleme verursacht. In fast jeden Crash Report steht was mit sun.reflect, com.google.common.eventbus und sowas. Wegen dem ''sun.reflect'' dachte ich erst der Shader Mod ist daran Schuld was jedoch nicht der Fall war. Was sagt mir in einem Crash Report welche Mods Inkompatiblitäten veraursachen? Ein Beispiel Report ist weiter unten wobei ich den ''Plant Mega Pack'' Mod installiert habe und aufeinmal im Report was mit Tinker's Construct und Project Red steht obwohl diese Mods vorher miteinander kopatibel waren. Kann mir da jemand helfen? Ich habe übrigens das Resonant Rise Mod Pack vom AT Launcher mit aktuell mehr als 300 Mods.

---- Minecraft Crash Report ---- // Would you like a cupcake?

Time: 3/9/16 6:28 PM Description: There was a severe problem during mod loading that has caused the game to fail

cpw.mods.fml.common.LoaderException: java.lang.RuntimeException: Invalid id 8865 - maximum id range exceeded. at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:239) at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:188) at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:177) at mrtjp.projectred.compatibility.tconstruct.PluginTConstruct$.init(PluginTConstruct.scala:60) at mrtjp.projectred.compatibility.Services$$anonfun$doInit$1.apply(Services.scala:48) at mrtjp.projectred.compatibility.Services$$anonfun$doInit$1.apply(Services.scala:48) at scala.collection.immutable.List.foreach(List.scala:383) at mrtjp.projectred.compatibility.Services$.doInit(Services.scala:48) at mrtjp.projectred.compatibility.CompatibilityProxy_server.init(proxies.scala:16) at mrtjp.projectred.ProjectRedCompatibility$.init(ProjectRedCompatibility.scala:20) at mrtjp.projectred.ProjectRedCompatibility.init(ProjectRedCompatibility.scala) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:532) at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) at com.google.common.eventbus.EventBus.dispatchQueuedEvents(

Antwort
von Freekzy, 69

sende mal den Launcher Log:

Einleitung:

1. %appdata%

2. .minecraft

3. logs

4. runter scrollen und den letzten Ordner öffnen und die ersten 13 Zeilen Kopieren und hier Einfügen.

Kommentar von MCMeister ,

EnderIO: Found the following problem(s) with your installation:
* Optifine is installed. This is NOT supported.
* The RF API that is being used (1.7.10R1.0.2 from ) differes from that that is reported as being loaded (1.7.10R1.0.13 from ENDERIO-1.7.10-2.3.0.422_BETA.jar).
It is a supported version, but that difference may lead to problems.
* Our API got loaded from ENDERIO-1.7.10-2.3.0.422_BETA.jar. That's unexpected.
* Our API got loaded from ENDERIO-1.7.10-2.3.0.422_BETA.jar. That's unexpected.
* Our API got loaded from ENDERIO-1.7.10-2.3.0.422_BETA.jar. That's unexpected.
* Our API got loaded from ENDERIO-1.7.10-2.3.0.422_BETA.jar. That's unexpected.
This may have caused the error. Try reproducing the crash WITHOUT this/these mod(s) before reporting it.
Stencil buffer state: Function set: GL30, pool: forge, bits: 8
Forestry : Warning: You have mods that change the behavior of Minecraft, ForgeModLoader, and/or Minecraft Forge to your client:
Optifine
These may have caused this error, and may not be supported. Try reproducing the crash WITHOUT these mods, and report it then.
OptiFine Version: OptiFine_1.7.10_HD_U_D1
Render Distance Chunks: 12
Mipmaps: 4
Anisotropic Filtering: 1
Antialiasing: 0
Multitexture: false
OpenGlVersion: 4.5.0 NVIDIA 359.06
OpenGlRenderer: GeForce GTX 750 Ti/PCIe/SSE2
OpenGlVendor: NVIDIA Corporation
CpuCount: 6
[18:28:52] [Client thread/INFO] [STDOUT/]: [net.minecraft.client.Minecraft:func_71377_b:359]: #@!@# Game crashed! Crash report saved to: #@!@# C:\Users\TheMeister\AppData\Roaming\at_launcher\Instances\ResonantRise\crash-reports\crash-2016-03-09_18.28.51-client.txt

das sind die letzten 13 zeilen aus fml-client-latest das müsste richtig sein

also ich habe als letztes den Plant Mega Pack mod istalliert und möchte den dazu inkopatiblen mod löschen (wenn es ein unwichtiger mod für mich ist)

Kommentar von MCMeister ,

Falls hier gemeint ist dass EnderIO nicht mit Optifine kompatibel sein soll, kann das nicht sein denn ich habe vor Feed the Beast auch mit Optifine und EnderIO gespielt und alles lief super.

Keine passende Antwort gefunden?

Fragen Sie die Community