Frage von kami1983, 31

Wie kann ich auf Inhalte von Zellen reagieren?

Hallo alle zusammen!

Ich habe in Spalte A1 100 Zeilen mit verschiedenen Texten in welchen Städtenamen enthalten sind. Nun möchte ich, dass mir in der jeweiligen Zelle rechts des Textes automatisch das Bundesland angezeigt wird zu dem die Stadt gehört.

Mit =WENN... wird es wohl nicht funktionieren da ich gelesen habe, dass man diese Funktion max. 7 mal verschachteln kann.

Bin für jeden Rat dankbar!

Beste Grüße

Antwort
von kami1983, 17

Grundprinzip verstanden!

Jedoch habe ich noch ein Problem.

In Tabelle 1 Spalte A1 steht "Der höchste Kamin Deutschlands steht in
Helmstedt".
In Tabelle 2 A1 steht "Helmstedt" und in B1 "Niedersachsen"
Wenn ich nun in Tabelle1 B1 folgenden Verweis erstelle:

=SVERWEIS(A1,SVERWEIS!A1:B200,2,0)

Dann zeigt er mir logischerweise nicht "Niedersachsen" da er ja nach
dem kompletten Zelleninhalt sucht. Gebe ich in Tabelle2 A1 "Der höchste Kamin Deutschlands steht in Helmstedt" ein so yeigt er mir in Tabelle1 B1 auch "Niedersachsen" an.

Nun habe ich "*" gefunden.

Verändere ich nun den Verweis in:

=SVERWEIS("*"&A1&"*",SVERWEIS!A1:B200,2,0)

so kann ich in Tabelle2 A1  "!%&^*$Der höchste Kamin Deutschlands steht in Helmstedt^&*^%$" eingeben und er zeigt mir trotzdem in Tabelle1 B1 "Niedersachsen" an.

Ich brauch es ja aber umgedreht.

Stehe etwas auf m Schlauch!

Kommentar von Oubyi ,

Ich sehe da ein prinzipielles Problem.
Wie willst Du Excel klar machen, dass der Ort nach dem Du suchst "Helmstedt" ist und nicht "Kamin"?
Verstehst Du, was ich meine?
Wenn es eine Möglichkeit gäbe, statt "Helmstedt" "#Helmstedt" zu schreiben, könnte man nach dem Wort nach "#" suchen und es in der Länderliste finden.
Aber ohne einen Anhaltspunkt, WELCHES Wort der Ort ist sehe ich da im Moment keine Lösung.

P.S.:
Mir fällt gerade noch ein:
Wenn Du die Anzahl der Worte im Suchsatz begrenzen kannst (also nicht mehr als 15 Worte oder so), kann man evtl. Stück für Stück nach jedem einzelnen Wort in der Länderliste suchen. Wäre zwar unschön, aber wohl machbar.
(ICH werde Dir da heute leider nicht mehr helfen können, schaue aber auf jeden Fall morgen nochmal rein.)

Kommentar von kami1983 ,

Habe es nun mit ner MATRIX und INDEX hinbekommen

={INDEX(Tabelle2!$B$1:$B$200,MAX(WENN(ISTFEHLER(SUCHEN(Tabelle2!$A$1:$A$200,A1)),"",ZEILE(Tabelle2!$B$1:$B$200))))}

Habe keinen Schimmer was da steht aber es hat mir geholfen :)

Kommentar von kami1983 ,

grmpf... hats doch nicht

Kommentar von kami1983 ,

Berichtige mich... das ist doch des Rätsels Lösung!
Man darf allerdings den Bereich in Tabelle2 B nur so weit definieren wie auch Datensätze vorhanden sind.
Sonst erscheint in Tabelle1 B1 NULL

Expertenantwort
von DeeDee07, Community-Experte für Excel, 25

Für sowas verwendet man sinnvollerweise einen SVERWEIS oder ähnliche Funktionen. Natürlich muss dafür zunächst eine Zuordnungstabelle (Stadt - Bundesland) erstellt werden, auf die man sich beziehen kann.

Im übrigen, seit Excel2007 sind mehr als 7 Verschachtelungen möglich. Trotzdem ist die Verwendung solcher Bandwurmformeln recht problematisch, da unübersichtlich.

Antwort
von FGO65, 27

Geht mit SVERWEIS

Kommentar von kami1983 ,

Danke! Dann werd ich mich mal schlau machen!

Keine passende Antwort gefunden?

Fragen Sie die Community