Frage von MicroZocker, 38

Wie installiere ich den CoFH Core mod, sodass ich ihn als API verwenden kann?

Also ich habe vor ein addon für den Redstone-Arsenal mod zu schreiben.

leider brauche ich dafür die beiden mods sprich CoFH Core und Redstone-Arsenal. ich bekomm nur beide mods nicht vernüftig in Eclipse integriert. entweder es schreit, dass Klassen fehlen oder, dass mein Forge veraltet ist (Was natürlich nicht stimmt) oder es zeigt die Mods nicht an.

Danke schonmal für alle Antworten

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von androhecker, 24

https://github.com/CoFH/RedstoneArsenal
Redstone Arsenal benutzt Gradle als Build Tool, das sollte dir alles runterladen, was du brauchst.

Kommentar von MicroZocker ,

danke erstmal :) muss ich da dann sicher nicht voher den CoFh installiert haben?

Kommentar von androhecker ,

Wie schon gesagt, sollte alles von Gradle geregelt werden.

Kommentar von MicroZocker ,

sprich einfach setupDecompWorkspace und fertig?
Weil da spuckt mir gradle aus:

A problem occurred evaluating root project 'RedstoneArsenal-master'.
> 1.7.10-10.13.4.1448 is an invalid version! did you mean '1.7.10-10.13.4.1448-1.7.10' ?

und ich hab keine Ahnung was ich daran ändern kann

Kommentar von MicroZocker ,

ok, hab nach bisschen suchen den eintrag mit der version gefunden und abgeändert... gradle ist durchgelaufen ohne Fehler. Jz muss ich das ganze nur noch in eclipse eingliedern... also wenn ich gradle eclipse eingebe und dann eclipse öffne kommen hundert Fehler dass irgendwelche Klassen fehlen. Es sieht aus als würde der CoreMod fehlen.Wenn ich aber den installiere fehlen wiederum andere Klassen. mussich noch irgendwas in den buildpath einfügen?

Kommentar von androhecker ,

Hat wohl ein Problem mit der Forge Versionsnummer, ändere sie einfach zu der vorgeschlagenen.

Kommentar von MicroZocker ,

ok, hab nach bisschen suchen den eintrag mit der version gefunden und abgeändert... gradle ist durchgelaufen ohne Fehler. Jz muss ich das ganze nur noch in eclipse eingliedern... also wenn ich gradle eclipse eingebe und dann eclipse öffne kommen hundert Fehler dass irgendwelche Klassen fehlen. Es sieht aus als würde der CoreMod fehlen.Wenn ich aber den installiere fehlen wiederum andere Klassen. mussich noch irgendwas in den buildpath einfügen?

Antwort
von Kenny537, 21

Schau mal welche Forge Version die beide Mods brauchen.

Wenn es nicht die selbe ist, kann es daran liegen, wenn beide die selbe Version brauchen musst du schauen dass du genau die version hast die die beiden Mods benötigen.

Keine passende Antwort gefunden?

Fragen Sie die Community