Frage von Skamqi, 38

Wie funktioniert die WENN()-Funktion in Excel?

Hallo Community,

wollte mal fragen ob sich hier jemand für einen nooby erbarmen kann und mir die WENN-Funktion erklären kann (Also wie die Syntax ist und wie das alles funktioniert.

Bin noch totaler Neuling im Excel Gebiet und würde echt gerne besser durchsteigen!

Liebe Grüße,

Skamqi

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von iMPerFekTioN, 28

Hallo du,

die =WENN()-Funktion

besteht eigentlich aus 3 Teilen, der Abfrage, dann was passieren
soll, und was sonst passieren soll, wenn die Abfrage nicht zutrifft.

Du hast also folgenden Aufbau =WENN([Abfrage];[Sonst-Wert];[Dann-Wert])

Aufgerufen wird die Funktion durch das = Zeichen, dann kommt der Funktionsaufruf WENN (Also die Wenn-Funktion) Die Einzelnen Teile der Wenn-Funktion werden durch Semikolon abgegrenzt (Strichpunkt - ;)

So kannst du deiner Funktion z.B. sagen, du willst den Wert aus Zelle B1
überprüfen, und wenn dieser Wert = deinen Vorstellungen entspricht, soll etwas in der Zelle der Formel stehen (also in der wo du die Wenn-Funktion anwendest) wie z.B. „Trifft zu“, wenn das dann NICHT der Fall ist, soll in der Zelle „Trifft nicht zu“ stehen!

Dann hättest du z.B. in der Zelle A1 folgende Funktion stehen:

=WENN(B1=“Test“;“Trifft zu“;“Trifft nicht zu“)

Abgeschlossen wird die Formel dann wieder mit einer geschlossenen Klammer!

Um Text über eine Funktion zu schreiben, muss dieser in
Anführungszeichen „ “stehen!

Das wars auch eigentlich schon!

In Excel gibt es außerdem den Formelassistenten, den findest du oben Links neben der Eingabezeile. Dort kannst du nach Funktionen suchen und die die Syntax und den Aufbau anzeigen lassen!

Liebe Grüße,

iMPerFekTioN

Antwort
von sternstefan, 21

Beispiel:  =Wenn(A1>9;"zweistellig";"einstellig")

Sprich: Wenn Wert in Zelle A1 größer als 9; dann "zweistellig" als Text ausgeben (Zahlen sind ohne Anführungszeichen einzugeben); ansonsten "einstellig" als Text ausgeben.

Vor dem ersten Strichpunkt steht also die Bedingung, die geprüft werden soll. In der Mitte steht die Anweisung für den Fall, dass die Bedingung erfüllt wird und am Ende die Anweisung für den Fall, dass die Bedingung nicht zutrifft.

Kommentar von iMPerFekTioN ,

Wenn du bei deiner Formel jetzt aber -10 eingibst ist das trotzdem einstellig :p

Kommentar von sternstefan ,

Negative Zahlen werden natürlich über "Gültigkeit" ausgeschlossen. Und es sind auch nur ganze Zahlen erlaubt. :)

Antwort
von Easy4MeInfo, 2

hier noch ein kleines Video, das die praktische Anwendung der wennn-Funktion vorführt:

Expertenantwort
von Oubyi, Community-Experte für Excel, 17

Peter macht das sehr gut:

http://www.online-excel.de/excel/singsel.php?f=95

Auch für weitere Fragen solltest Du Dir seine HP merken.

Kommentar von iMPerFekTioN ,

Ach sorry Oubyi, da hab ich mich total verklickt :(
Hab dir ausversehen nen Pfeil runter gegeben (Schande über mein Haupt)

Die Seite ist der Hammer, ähnlich wie das Herber Excel-Forum!

Antwort
von Janni1907, 24

Knappe Erklärung: =WENN(Was zutreffen soll;Dann;Ansonsten)

Also z.B. =WENN(A1 = 2;Korrekt;Falsch!) oder auch =WENN(A1 = Banane;Lecker!;Ich mag keine Bananen)

Hoffe man kann es so halbwegs verstehen

Kommentar von iMPerFekTioN ,

Also, die Erklärung war echt super gemeint, aber das 2. Beispiel ist echt komisch =D

Wenn du in A1 Banane stehen hast, sagst du "ach lecker"!
Wenn in A1 jetzt Apfel steht sagst du "Ich mag keine Bananen" was dann aber rein gar nichts mit der Zelle 1A1 zu tun hat.

Für ein Neuling also evtl etwas verwirrend :P

Trotzdem toll erklärt :p

Kommentar von Janni1907 ,

Ja gut ok hab ich gesagt ;D

Keine passende Antwort gefunden?

Fragen Sie die Community