Frage von horst9999, 42

Werte zählen in Excelspalte?

Hallo Excelexperten!

Ich suche eine Formel, mit der ich Werte zählen kann, Beispiel:

Spalte A

345

567

567

567

345

123

Das Ergebnis der Formel soll dann also lauten:

345 2

567 3

123 1

gibt es hier eine einfache Lösung? (Ich habe hier excel 2007)

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 20

Zwei Möglichkeiten:

1. Du kopierst die Werte in eine eigene Spalte und wählst unter Daten > Duplikate entfernen, wobei das bei Deiner Excelversion vermutlich noch etwas anders heißt. Die Funktion selbst ist auf jeden Fall da.
Neben die erste Zeile der bereinigten Werte dann =zählenwenn(A:A;D1) wobei A die Spalte ist, in der gezählt werden soll und D1 hier der erste Wert in der bereinigten Liste ist, s. Bild

2. Pivottabelle - findet sich unter Einfügen. Dazu braucht Deine Spalte eine Überschrift (egal was, ist nur einer Voraussetzung, dass die Pivottabelle erstellt werden kann).
Markier die Zelle, wo die Pivottabelle erstellt werden soll > dann auf erstellen. Bei "Tabelle oder Bereich auswählen" markierst Du die Spalte mit den Werten, die gezählt werden sollen. Unten bzgl. Ort, wo die Tabelle erstellt werden soll, musst Du nichts ändern.
Auf dem sich dann öffnenden Formular ziehst Du die angezeigte Überschrift in den Bereich Zeilen und Werte s. Bild.
In meinem Beispiel hat Excel angenommen, dass die Summe gebildet werden soll - richtig wäre aber die Anzahl. Daher auf den kleinen schwarzen Pfeil bei "Summe von Werten" gehen > Wertfeldeinstellungen und dort auf Anzahl wechseln.

Pivot hört sich sicherlich komplizierter an, es schadet aber nicht, diese Möglichkeit zu kennen. Gerade wenn sich die Werte häufig ändern, lässt sich die Auswertung mit Pivot leicht aktualisieren, während die Formellösung immer manuellen Aufwand erfordert.

Kommentar von horst9999 ,

Hallo Ninombre,
vielen Dank für die ausführliche und gut nachvollziehbare Antwort.
Es ist immer wieder überraschend, wie einfach doch manchmal eine Lösung ist - wenn man sie kennt ;-)
Die Pivotlösung ist ja auch interressant, kann ich sicher auch mal verwenden - die Pivottabelle ansich scheint ja auch sehr viel Potential zu haben...
Auf jeden Fall hast du mir sehr geholfen! Nochmals Danke!

Kommentar von iMPerFekTioN ,

Was wäre dieses Portal ohne euch =) Danke Ninombre für deine jahrelange Beitragskraft!

Antwort
von IronofDesert, 25

Hallo Horst9999

Wenn dir vorher bekannt ist was du zählen möchstest würde das mit dieser Formel gehen:

=ZÄHLENWENN(A2:A7,"DEINWERT")

A2:A7 ist dann der Bereich in dem Gezählt werden soll und DEINWERT was gezählt werden soll. Hier könntest du dann z. b. 345 rein schreiben

Gruß

Kommentar von horst9999 ,

Vielen Dank!
Die Lösung ist sehr gut, um nur einen der Werte zu zählen, kann ich bestimmt auch mal gebrauchen.

Kommentar von IronofDesert ,

Du kannst die Formel natürlich auch Variabel schreiben. Statt DEINWERT kannst du auch einfach einen Zellbezug wie z. b. B5 machen. Dann kannst du in das Feld B5 reinschreiben was er suchen soll.

Kommentar von horst9999 ,

ja, "Ninombre" hat das in seiner Antwort sehr gut auf den Punkt gebracht...

Keine passende Antwort gefunden?

Fragen Sie die Community