Werte aus Funktion im Diagramm anzeigen?

... komplette Frage anzeigen

4 Antworten

LINKS und RECHTS sind Textfunktionen. Wenn du diese Funktionen benutzt, dann wird das Ergebnis ein Text, der im Diagramm als 0 angezeigt wird.

Am besten wäre es, wenn man die reinen Beträge von vornherein in einer eigenen Spalte als Zahl erfasst, dann spart man sich die Umwandlung und kann allgemein Informationen besser verarbeiten.

Falls das nicht (einfach) geht, weil z.B. die Sätze so importiert wurden, kannst du die Text-Funktionen mit WERT umschließen. Daraus wird die Text-Zahl wieder zu einer echten Zahl, die dann im Diagramm auch so angezeigt wird.

Du brauchst auch keine zwei Spalten für die Extraktion, sondern kannst es auch direkt herauslösen, mit:

=WERT(LINKS(RECHTS(....)))

Verwendest du für die Zeichenlänge feste Werte? Oder suchst du nach Leerzeichen? Im ersten Fall wird es Probleme geben, wenn die Zahlen unterschiedlich viele Stellen haben.

Antwort bewerten Vielen Dank für Deine Bewertung

rechts() und links() sind Textfunktionen und liefern Text. Du muss in einer Hilfsspalte diese Texte *1 nehmen, dann wandelt xl alles, was umwandelbar ist, zu Zahlen um.

Kannst das dann ALSWERTE (Icon 123) wieder draufkopieren und die Hilfsspalte löschen

Die Werte (sind ja jetzt Zahlen) solltest du dann auch im Diagramm sehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
30.09.2016, 11:07

Es geht übrigens auch in einem Aufwasch (Zeile2 und unter der Voraussetzung, dass vor und nach der Zahl je ein Leerzeichen steht, auch für 3-stellige Zahlen.):

=WENNFEHLER(1*(LINKS(RECHTS(A2;5);4));0)

(oder auch ohne Wennfehler() ).

Aber vermutlich willst Du die Zahl als Wert wieder am Ausgangsort zurückhaben, so dass Du Dir das Kopieren und ALSWERTE einfügen nicht sparen kannst.


Es geht aber auch mit längeren Zahlen (xl verwertet max 15 Stellen + Komma). Der Eintrag

Die Montagszahl war 1234567890123,45 €

wird durch die Formel

=Wennfehler(1*(Links(Rechts(Wechseln($A$2;" ";" ");33);17));0)

so umgewandelt:

1234567890123,45

jede kürzere Zahl ebenfalls richtig. Kann man Bendef so formatieren:

###.###.###.###.###,00;[Rot]-###.###.###.###.###,00;[Magenta]°

Das lässt das Ändern der Nachkommastellen per Icon zu

0

Ändere die Formel in:

=LINKS(.....)*1

Dann sollte es klappen.

P.S.:
Falls dann immer noch die € dahinter zu sehen sind, liegt das daran, dass Excel die Zelle automatisch als Währung formatiert hat, was aber nichts aus macht, das Diagramm klappt trotzdem. Wenn Dich das stört formatiere einfach wieder als Zahl.


Antwort bewerten Vielen Dank für Deine Bewertung

Sind bei der Auswahl was angezeigt werden soll, alle Spalten/Zeilen eingestellt? 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von wiedermalich
29.09.2016, 23:42

Bei der Auswahl habe ich nur die Spalte darstellen lassen und "erste spalte als titel" ebenso wie "erste zeile als titel" deaktiviert.

die 50, die ich ovn hand rein schriebe taucht dann ja auch auf :(

0

Was möchtest Du wissen?