Wer kennt die Excel Formel für mein Problem?

... komplette Frage anzeigen

2 Antworten

einfach an die Formel in meiner AW auf Deine Frage

www.gutefrage.net/frage/wer-kann-mir-mit-einer-excel-formel-helfen

ein &" Schrauben" dranhängen  und wieder als Matrixformel eingeben!

{=SUMME(WENN(NICHT(ISTFEHLER(FINDEN("Schraube";$A$1:$B$4;1)));1;0)*WENN(ISTZAHL(LINKS($A$1:$B$4;2)*1);LINKS($A$1:$B$4;2);0))&" Schrauben"}

Es ist aber schlechter xl-Stil, Zahlen und Text in eine Zelle zu schreiben, das bringt Dir doch keinen Vorteil! Diese ganze komplizierte Formel, die Du selber gar nicht mehr entwickeln/korrigieren kannst (und ich nur mit Mühe!) braucht es nur deshalb!

ich hab übrigens nachgeprüft, die Formel wird ab 10 Mio Zellen zunächst ein wenig, dann merklich langsamer, bei 50 Mio Zellen braucht sie ca. 20 sec (bei mir in der momentanen Konstellation), das ist zB $A:$AZ in einem anderen Blatt. Irgendwann meldet xl dann einen Fehler in der Formel, was aber nur der Kapazität geschuldet ist.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
06.02.2016, 16:38

Das kommt eben von der Einstellung Excel kann jeder, ist ja logisch da braucht man keine Grundlagen.
Und dann wird es einfach als "Word für Tabellen" verwendet

1
Kommentar von Sorrisoo
06.02.2016, 17:58

Vielen Dank. Werde es ausprobieren. Ich kenne mich mit Excel leider nicht gut aus😞Und mit Komplizierten Formeln sowieso nicht. Sorry wenn ich euch auf  die Nerven gehe, aber ich dachte mir, hier kann man alles fragen. Und wenn mir jemand helfen kann, dann hier.

0
Kommentar von Sorrisoo
06.02.2016, 20:55

Iamiam Du bist der Hammer! Es funktioniert. Das hätte ich nie lösen können. Vielen Dank👍🏻

0

Die Anmerkungen waren sicherlich nicht böse gemeint (denn Iamiam hat sich die Mühe gemacht, trotzdem eine Lösung auszutüfteln !), sind aber schon richtig, es wird verdammt kompliziert. Excel ist halt eine Tabellenkalkulation, und obwohl noch sehr viel mehr geht, kommt man dann in den Bereich, wo man eigentlich das Programm zweckentfremdet. Moralisch nicht verwerflich, wird aber kompliziert bzw. darf man sich nicht beschweren, warum Excel zickt.

Wäre es denn eine Alternative, wenn nur die Anzeige mit Schraube ist? Über Zellen formatieren > benutzerdefiniert kann man ziemlich viel machen. Und wichtig dabei: In der Zelle steht weiterhin nur eine Zahl, mit der man ganz normal rechnen kann, nur in der Anzeige wird der Text hinzugenommen, s. Bild:

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sorrisoo
06.02.2016, 19:28

Das mit dem Text formatieren, habe ich auch schon gelesen. Wäre ev. eine Alternative. Vielen Dank.

0
Kommentar von Ninombre
06.02.2016, 19:42

bild kann man so natürlich nicht erkennen. Die Eíngabe bei benutzerdefiniert wäre # "Schrauben"

0

Was möchtest Du wissen?