Wer kann mir bei einem Problem in Excel helfen?

... komplette Frage anzeigen

2 Antworten

Um aus "U5" eine ZAHL zu erhalten, folgende Formel:

(Unzuwandelnder Wert "U5" steht in A1)

=WECHSELN(A1;"U";" ")*1

Es wird das "U" in ein Leerzeichen gewechselt, also in " 5" (Anzeige linksbündig)
Die Multiplikation macht daraus eine ZAHL (Anzeige rechtsbündig).

Unerheblich hierbei ist die Anzahl der Ziffern nach dem Buchstaben.

Gruß aus Berlin

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Britzcontrol
21.11.2015, 07:47

Sollen jetzt (innerhalb einer Zeile) MEHRERE Werte (hier D12 bis AH12) berechnet werden:

{=SUMME(WECHSELN(D12:AH12;"U";" ")*1)}

Achtung Matrixformel, Eingabe (ohne geschweifte Klammern) mit STRG+UMSCHALT+RETURN abschließen.

Ist damit Deine Frage beantwortet ?

Gruß aus Berlin

0

Vielleicht biegt noch jemand mit einer genialen Formel um die Ecke, die dürfte dann aber nicht ganz trivial sein. Alternativvorschlag, der Dir bei künftigen Änderungen der Formeln vielleicht das Leben einfacher macht:

Unter jede Mitarbeiterzeile noch eine weitere anlegen. Diese kann später wieder ausgeblendet werden. Dort einfach
=WENN(LINKS(D14;1)="U";RECHTS(D14;LÄNGE(D14)-1);"")

Dann bleiben nur die Zahlenwerte der U5, U8 usw. übrig, die ganz normal weiter verarbeitet werden können.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von QuiMi
20.11.2015, 15:31

Hallo Ninombre,

schon mal vorab vielen Dank. Ist die Formel zellenbezogen, oder kann ich die auch auf einen Bereich anwenden?

0

Was möchtest Du wissen?