Frage von saschaauch, 72

Wer kann bei der Erstellung folgender Formel helfen (vereinfacht dargestellt)?

In einer Spalte hinterlege ich 10 Werte in den Feldern C1 – C10 (z.B. C1=1000, C2=2000, C3=2500, C4=5000 etc) In der nächsten Spalte (D1- D10) hinterlege ich ebenfalls 10 Werte (z.B. D1=50, D2=60, D3=90, D3=20 etc). Nun möchte ich folgendes berechnen: In Feld A1 trage ich einen Wert aus der Spalte C manuell ein (z.B. 1000). In Feld B1 muss dann 1000-50 (Ergebnis 950) gerechnet werden. Es muss immer der Wert aus der D Spalte von dem Wert aus der C Spalte in der gleichen Zeile subtrahiert werden. Z.B. C2-D2(2000-60), oder C3-D3(2500-90) oder C4-D4(5000-20) usw. Wie geht die Formel. (zur Info: ich habe Excel 2007)

Expertenantwort
von Oubyi, Community-Experte für Excel, 55

=A1-INDEX(D1:D10;VERGLEICH(A1;C1:C10;0))

Klappt es?

Kommentar von saschaauch ,

Ja, super, funktioniert genau so, wie es soll. Vielen Dank

Kommentar von Oubyi ,

Gern geschehen ☼

Antwort
von Jake1865, 24

Hier mal im Bild

Kommentar von saschaauch ,

Es soll so seien, dass ich in einem beliebigen Feld zwischen A1 und A400 einen dieser 10 Werte (die in der Spalte C hinterlegt sind) eintragen kann. In die B Spalte trage ich nichts ein. Dort soll nur das Ergebnis stehen. So lange das Feld in der A Spalte leer ist, ist es egal, was in der B Spalte erscheint. Wichtig ist jedoch: das Ergebnis in der B Spalte muss immer in der gleichen Zeile liegen, in der ich den Wert in der A Spalte eingetragen habe. Auf deinem Beispielfoto müsste das Ergebnis in B1 stehen. Die Spalten C und D könnten mit entsprechender Verlinkung auch auf einem anderen Blatt stehen, da sie nur für die Berechnung benötigt werden. ... Aber, so wie schon oben geschrieben, funktioniert für mich die Formel von oubyi.  Danke nochmal.

Antwort
von Tron1701, 9

Hallo,

funktioniert auch mit dieser Formel in B1.

=SVERWEIS(A1;C1:D10;1)-SVERWEIS(A1;C1:D10;2)

Gruß Tron

Kommentar von saschaauch ,

habe ich probiert, geht, danke

Antwort
von Jake1865, 43

Moin,

also wenn du IMMER C1-D1 usw. rechnest, brauchst du diese Formel doch nur in B1 einzutragen und dann die Formel runterziehen?

Oder möchtest du nur dann ein Ergebnis in B1 anzeigen wenn in A1 etwas eingetragen ist?

die Formel in B1 sieht dann so aus: =wenn(a1=c1;c1-d1;"")

oder allgemeiner wenn es nur um irgendeine Markierung in a1 geht (z.B. ein x)   =wenn(a1="";"",c1-d1) Die Formel bedeutet wenn in a1 nichts steht,schreibe nichts in b1, ansonsten rechne c1-d1.

Gruß Jake


Kommentar von iMPerFekTioN ,

Und was machst du, wenn z.B. der Wert 2000 in C1 und C2 steht?
Wenn jetzt C2 - D2 rechnen will, du aber in der Formel hast:;

=wenn(A1=C1;C1-D1;WENN(A1=C2;C2-D2;"")

(nur mal als Beispiel)
Dann wird immer nur C1-D1 gerechnet weil dieser Wert zuerst auftritt.

Angenommen es steht in C1 1000 und in D1 900

Dann wäre das Ergebnis ja 100

In C2 steht 1000 und in D2 steht 500, dann wäre das Ergebnis 500.

Er will jetzt die 500 haben bekommt aber immer nur die 100 raus :)

Kommentar von Jake1865 ,

diese Formel kommt doch gar nicht vor. Jede Zeile wird doch für sich berechnet, wenn ich die Frage richtig verstanden habe:

"Es muss immer der Wert aus der D Spalte von dem Wert aus der C Spalte in der gleichen Zeile subtrahiert werden. Z.B. C2-D2(2000-60), oder C3-D3(2500-90) oder C4-D4(5000-20) usw."

Also wird immer nur der Wert aus der selben Zeile gerechnet ohne irgendwelche Vergleich mit anderen Zeilen.


Kommentar von iMPerFekTioN ,

Ja richtig!Trotzdem, es wird doch ein Wert in Zelle A1 eingetragen, du hast den Wert A1 mit C1 verglichen, wenn dieser gleich war hast du C1 - D1, wenn jetzt aber der Wert C1 und und C2 gleich ist, und er 1000 einträgt wird nur C1 - D1 berechnet aber  C2 - D2 würde gar nicht dazu kommen.

Kommentar von Jake1865 ,

ich bin davon ausgegangen, das er jeweils in a1 , a2 usw. einen Wert einträgt oder es bleiben läßt und dann die Berechnung Zeilenweise erfolgt. 

Ansonsten müßte man es tatsächlich mit der u.g. Indexfunktion lösen.

Kommentar von Jake1865 ,

oder so:

in Zelle b1 eintragen =wenn($a$1=c1;c1-d1;"")

Es wird immer dann gerechnet wenn in einer c Zeile der Wert aus a1 auftaucht.

die formel dann runterziehen.

Habe eine Antowrt mit Bild dazu erstellt.


Kommentar von saschaauch ,

Danke für die Antwort. Es funktioniert aber nur Teilweise. Bei der Formel =WENN(A1=C1;C1-D1;C2-D2) funktioniert es. Aber sobald ich eine drittes Feld Paar hinzufüge ...C3-D2 kommt die Meldung "zu viele Argumente". Der Vorschlag von Oubyi funktioniert, und den nutze ich jetzt.

Kommentar von Jake1865 ,

das ist ja auch nicht die Formel die ich angegeben habe. Siehe Bild! Aber da es jetzt funktioniert ist das Thema wohl durch.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten