Frage von Beweis91, 33

=+WENN((D17:D22)=0;"-";(D17*(D18-(D19+D20)/60))*D21)*D22 was ist falsch daran es kommt #Wert! die zellen D17:D22 sind aber leer dann sollte "-" stehen oder?

Expertenantwort
von Oubyi, Community-Experte für Excel, 24

...sollte so funktionieren wenn in den Zellen D17 bis D22 nichts steht also
der wert 0 ist dann sollte ein "-" stehen, sobald in die zellen ein
WErt eingetragen wird soll die Formel (D17*(D18-(D19+D20)/60))*D21)*D22
angewendet werden.

Erstmal ist in Deiner Formel ein Klammerfehler.
Außerdem gehe ich mal davon aus, dass nur gerechnet werden soll, wenn ALLE Zellen im Bereich D17:D22 ausgefüllt sind.
Dann:

=WENN(ANZAHL(D17:D22)<>6;"-";(D17*(D18-(D19+D20)/60)*D21)*D22)

Klappt es?
Oder war es doch anders gemeint.

Kommentar von Selitos ,

Ich schließe mich Oubyi dahingehend an, als dass bei deiner Formel im ersten Teil einfach die Funktion fehlt.

"Wenn((D17:D22)..." das ist einfach nur die Definition eines Zellbereichs (markiert sind die Zellen D17:D22).

Um das "Warum" zu klären.

Antwort
von Lilalaunebaer69, 28

Nichts ist bei Excel ja etwas anders als 0
Hast Du mal 0 in die Felder eingetragen ?
Ansonsten überprüfe doch mal den Typ der Zellen, ob das Text oder Zahl oder sonst etwas ist.

Kommentar von Iamiam ,

xl nimmt in den meisten Formeln leer für 0

Lediglich bei so Formeln wie =istzahl() etc wird unterschieden.

Ich hab vor kurzem in einer AW

www.gutefrage.net/frage/excel-welche-formel-fuer-leere-zeile?

geschrieben:

Du siehst, nichts ist komplizierter als NICHTS!

Antwort
von Ashuna, 28

=WENN(SUMME(D17:D22)=0;"-";D17*(D18-(D19+D20)/60)*D21*D22)

Kommentar von Beweis91 ,

Funktioniert so nicht bei mir hatte ich schon ausprobiert

Kommentar von Ashuna ,

Kopier das und setz es bei dir ein...

Kommentar von Beweis91 ,

geht nicht kommt immernoch #wert!

Kommentar von Ashuna ,

hast du denn werte in den Feldern? und wie ist/ sind die Zelle/n formatiert?

Bei mir funktioniert es so. Welches Excel nutzt du?

Kommentar von Beweis91 ,

2010 und nein  keine werte in den Zellen schreibe ich allerdings werte rein, dann funktioniert die Formel wie sie soll

Zellen sind nicht bewusst von mir formatiert also standart Excel formatierung

Kommentar von Ashuna ,

sollten die Zellen einfach Leer sein versuch mal ="" anstelle =0. Vlt hilft das. Ansonsten wie unten von Antitroll1234 erwähnt. Viel Glück.

Kommentar von Antitroll1234 ,

Dann hast Du vielleicht in irgendeiner Zelle von D17 bis D22 ein Leerzeichen, lösche mal die Inhalte mit "Entf" von D17 bis D22 und gib die Zahlen erneut manuell dort ein.

Kommentar von Ninombre ,

Dann sind mit hoher Wahrscheinlichkeit Leerzeichen in einer dieser Zellen. leer wird als 0 gerechnet, Leerzeichen ist aber nicht leer, sondern ein Text und damit kann nicht gerechnet werden, ergo Fehlermeldung.

Zwei Anmerkungen allerdings:
a) =summe(D17:D22)="" geht nicht "" ist ein Text und keine Zahl.

b) auf die Summe 0 abfragen bedeutet nicht, dass die Felder alle leer sind. Kann auch drei Mal leer und dann 1 und -1 sein. Ist unterm Strich auch 0. Daher ist der Lösungsweg von Oubyi sicherer mit Anzahl zu prüfen, ob wirklich alle 6 Felder mit einer Zahl gefüllt sind. Ansonsten ist eine Berechnung der Formel ja auch nicht möglich, egal ob leer oder Text in einem der Felder.

Kommentar von Oubyi ,

DH!
Nur noch ein kleine Anmerkung:
SUMME(D17:D22)=0
wäre auch WAHR für :
1 | 2 | 3 | -17 | 5 | 6 |


Antwort
von iMPerFekTioN, 12

Schon mal versucht:

=WENN((D17:D22)="";"-";(D17*(D18-(D19+D20)/60))*D21)*D22

Geht das?

Grüße,

iMPerFekTioN

Kommentar von Beweis91 ,

geht nicht

problem wurde von Ashuna gelöst

Kommentar von iMPerFekTioN ,

Deine Formel wird aber auch bei einer Leeren Zelle nicht greifen da 0 = FALSCH bedeutet und "" = Leer

D.h. eine Leere Zelle wird nicht mit = 0 aufgerufen!

Keine passende Antwort gefunden?

Fragen Sie die Community