Wenn Spieler mit ältere Versionen im Multiplayer auf Spieler mit neueren treffen?

... komplette Frage anzeigen

4 Antworten

Die meistem Spiele planen für die Zeit dann eine entsprechende Wartung. Auch bei solchen HTML5-Spielen gibt es vermutlich einfach eine Funktion, mit der der Entwickler die Spieler einfach alle kicken kann. Wenn es sowas jetzt allerdings nicht gibt... naja, dann würde es höchstwahrscheinlich bei Spielern zu Fehlern kommen, da die Server im Idealfall so programmiert wurden, dass sie nicht einfach so abschmieren.

Antwort bewerten Vielen Dank für Deine Bewertung

Der gameserver sollte im regelfall nach änderungen im Quelltext und demzufolge die neukompilierung sowieso neu gestartet werden. Spätestens dann sollte clientseitig nen versionsupdatecheck passieren

Antwort bewerten Vielen Dank für Deine Bewertung

Minecraft hat eine solches System, man kann mit mc version 1.10 und 1.9 auf einen 1.8 server joinen aber weil ja die anderen zwei moderner sind werden einfach die neuen blöcke nicht craftbar oder verfügbar sein

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von GluecklicheHuhn
23.08.2016, 08:01

Ah ja das kenne ich. Das ist natürlich eine sehr gute Lösung, ja.

0

Es wird wahrscheinlich das passieren:

Dein Browser versucht auf eine Datei die in der 1.0 existiert hat zuzugreifen.

z.b. Faust_Schlagen.php(nur als Beispiel)

Da aber die Fäuste entfernt wurden findet der Browser die Datei nicht mehr und wirft eine Fehlermeldung aus
(indem fall 404 Not Found). Du öffnest das Spiel erneut und du bekommst auch die 1.1 mit den Waffen.

oder das:

Der Server wird kurz gewartet, du kannst nicht mehr Spielen und nach 10min

geht der Server wieder und die 1.1 ist installiert.

Antwort bewerten Vielen Dank für Deine Bewertung