Frage von MrRaze, 35

WENN Formel bei Excle?

Hallo meine Formel heißt :
=WENN(UND(C32>0;C33>0);C6+C8+J6+J8;WENN(C32>0;C6+C8;J6+J8))

Das Problem ist jetzt das ich noch den Fall hinzufügen will : WENN(UND(C32<0;C33<0);0

Dann sagt Excel das es zu viele Argumente sind. Hat da jemand eine Lösung?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 7

Deine Fälle wirken sehr asymmetrisch. Ist das Absicht?

Sei C32=A und C33=B, C6+C8=S₁ und J6+J8=S₂

  A B Summe
  > > S₁ + S₂ > ≤ S₁ < < 0 S₂ sonst

Oder in einer Matrix: A↓B→ < ≤ = ≥ > < x ≤ = ≥ > x x x

Zum Beispiel fällt der Fall, dass wenn B = 0 ist und A größer als 0 in den Sonst-Zweig.

Ich kann mir vorstellen, dass du eigentlich Symmetrie erreichen möchtest. Hierfür lautet mein Vorschlag:

=(C32>0)*(C6+C8)+(C33>0)*(J6+J8)

(Ich beziehe mich auf Ninombres Interpretation deines Änderungswunschs)

Expertenantwort
von Ninombre, Community-Experte für Excel, 13

Deine bisherige Wenn-Formel ist nach J6+J8 zu Ende. Das ist das 2. "Sonst". Die zusätzliche Abfrage muss also nach dem 2. Dann kommen:

=WENN(UND(C32>0;C33>0);C6+C8+J6+J8;WENN(C32>0;C6+C8;WENN(UND(C32<0;C33<0);0;J6+J8)))
Antwort
von DODOsBACK, 10

Müsste funktionieren, wenn du den "Zusatz" als erstes Argument nimmst:

WENN(UND(C32<0;C33<0);0;WENN(UND(C32>0;C33>0);C6+C8+J6+J8;WENN(C32>0;C6+C8;J6+J8)))

Antwort
von beroud, 16

du schreibst leider nicht, in welcher reihenfolge abgefragt werden soll, aber "wenn" mußt du halt schachteln

wenn(bedingung; wahr; unwahr)

wenn(bedingung;     wenn(bedingung, wahr, unwahr)     ; unwahr)

oder

wenn(bedingung; wahr;     wenn(bedingung; wahr; unwahr)     )

da wird der fehler liegen - du wirst deine abfrage als viertes argument in eine wenn-abfrage gestellt haben

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten