Welche Funktion brauche ich, mit der ich Zeiten eingeben kann und Excel in einer anderen Tabelle nach der richtigen Zuordnung sucht?

... komplette Frage anzeigen

3 Antworten

Wenn  der Beginn jedes Intervalls nur als Zeit und isoliert in B2:B7 steht, dann in diesem speziellen Fall(1..6) die Fo in zB E2:

=VERGLEICH(WERT("16:30");B$2:B$7)

bzw. wenn in D3 die gefragte Uhrzeit steht:

=VERGLEICH(WERT(D3);B$2:B$7)  für den Beginn (die Wechselzeit wird schon dem nächsten Intervall zugeordnet und die Zeiten müssen steigend geordnet sein. Das WERT() könnte in diesem Fall auch entfallen, aber es schadet nichts)

und runterziehen.

Für andere Zahlen (Zeitzonen also nicht von 1..6, sondern willkürlich):

=INDEX(A2:A7;VERGLEICH(WERT(D3);B$2:B$7))

Willst Du auch die Verlassen-Zeit auswerten, kannst Du das in einer weiteren Zelle ganz analog tun.

Hast Du aber - wie beim Kopieren Deiner Angaben hier- Zeiten und Datum in einer einzigen Zelle stehen, dann musst Du eine Textauflösung vornehmen, zB

Teil(B2;11;5) oder, wenns Datum+Zeit ist, mit Rest(DatumZeitzelle;1) arbeiten. Hier dürfte bei Texten WERT(DatumZeitzelle) unerlässlich sein - ich hab die vielen Optionen nicht alle ausprobiert.

Antwort bewerten Vielen Dank für Deine Bewertung

Danke Euch für Eure Antworten. Ich habe mich falsch ausgedrückt, aber Eure Antworten haben weitergeholfen und mir neue Ideen für meine Tabelle zum Ergänzen gegeben. In Grunde genommen wollte ich, nur für die bestimmten Zeiten eine zugeordnete Nummer und die Funktion, sollte diese sozusagen für die richtigen Zeiten zuordnen. Sprich, ich gebe in einer anderen Tabelle, die unterschiedlichen Uhrzeiten der Besucher ein und die Funktion liest mir, die von mir festgelegte Zeitzone heraus. Wenn jemand um 16:00 Uhr kommt und um 17:00 geht, gehört er z.B. in die Zeitzone 6. Aufschlüsseln brauche ich nicht, mir reicht es, wenn die Funktion in die nächst größere Zugehörigkeit zuordnet. Ich habe es mit der Verweisfunktion hinbekommen :)

Antwort bewerten Vielen Dank für Deine Bewertung

Meine Zuordnung

Zone Zeitzonen 
1          08:00 9:45
2          09:45 11:30
3          11:30 13:00
4          13:00 14:45
5         14:45 16:30
6         16:30 18:15

Und mit der Funktion soll er mir bei folgender Tabelle die Zone automatisch raussuchen

Zone     von bis   Datum

   x          16:00 17:00 13.11.2015 Freitag

   x          11:15 11:25 17.11.2015 Dienstag

   x          09:42 10:30 18.11.2015 Mittwoch

Ich würde die Zonen anschließend in einem Diagramm verwerten können.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
01.12.2015, 12:10

Da die Folgezone immer mit dem Schlusswert der ersten beginnt, reicht es sowohl bei der Definition wie auch bei der Abfrage, die ersten 5 Zeichen auszulesen mit =Links(Bn;5), evtl noch Wert(..) drumrum und eine Zone 0 (vor 8:00) sowie eine Zone 7 (nach 18:15).

Was Du allerdings mit dem zweiten Wert, zB  17:00 anfangen willst, weiß ich immer noch nicht. Willst Du den Anteil der Nutzungszeit auf beide Zonen aufschlüsseln? also zB 16:00 bis 16:30 ==> 0:30 in Zone 5 und 17:00-16:30 ==>ebenfalls 0:30 in Zone 6? Das erfordert eine komplexere Formel, die ich erst entwickeln müsste. wäre aber kein Problem, "nur" Arbeit.

0