Frage von Hamu24, 43

Was muss ich bei excel eingeben, wenn ich wissen welche zahl und wie oft sie vorkommt?

Hallo ihr lieben,

ich brauche bitte eure Hilfe.

Es geht um die Häufigkeit einer Zahl in einer Excel tabelle. Ich möchte gerne wissen welche zahlen und wie oft sie in der Excel-tabelle vorkommen. Also ich habe mehrere Zahlen und möchte nur wissen welche zahl wie oft auftaucht.

kann mir bitte jemand dabei helfen :-)

Vielen Dank

Expertenantwort
von Iamiam, Community-Experte für Excel, 15

Für Spalte A: In Einer Hilfsspalte schreibst Du -zB in D1 (D für Doppel)- die Formel

=Zählenwenn(A$1:A$999;A1)

und ziehst sie runter bis zum letzten Zahleneintrag in A. Alles, was über 1 ist, sind "Doppel" (Tripel, Quadrupel etc inclusive)

Du musst aber bedenken, dass Mehrfachvorkommen auch an den anderen Orten ebenfalls mehrfach gezählt werden und Du auch keinerlei Aufschluss über den Ort des Doppels bekommst. Müsstest Du filtern oder die Formel modifizieren:

=Zählenwenn(A2:A$999;A1)

zeigt, dass noch ein Doppel unterhalb vorkommt.

(einfaches Vorkommen ist hier 0, Doppel liefern 1).

Ist auch das noch zu ungenau (Du willst wissen, in welcher Zeile das nächste Doppel steht), dann

=Vergleich(A1;A2:A$999;0)+Zeilen(A$1:A1)

Willst Du die Gesamtanzahl aller unterschiedlichen Zahlen, dann den Kehrwert von Zählenwenn:

=1/Zählenwenn(A$1:A$999;A1) am besten im Bruchformat. Die Spaltensumme dieser Formel liefert die gewünschte Anzahl. (eine dreifach auftretende Zahl liefert 1/3 und das 3 mal, in der Summe also 1 Das abgezogen von der Zahl, die =Anzahl() liefert, ergibt wieder die Summe der Mehrfachnennungen))

Willst Du das nicht für eine Spalte, sondern für eine Fläche haben, dann in einem anderen Blatt in A1:

=Zählenwenn(Blatt1!$A$1:$A$999;A1)

oder wieder 1/Zählenwenn(...) und das über die gesamte relevante Fläche kopieren. Die Vergleich()-Formel geht hier nicht, sie erfasst nur eine Spalte, da gäbs- um einiger komplizierter- aber auch Möglichkeiten.

Noch Fragen? Dann melde Dich!

Kommentar von Iamiam ,

 obiges =Zählenwenn(Blatt1!$A$1:$A$999;A1) in zB Blatt2!A1 muss korrekt heissen

=Zählenwenn(Blatt1!$A$1:$N$999;Blatt1!A1)

bzw

=1/Zählenwenn(Blatt1!$A$1:$N$999;Blatt1!A1)

denn Du musst den Wert ja mit dem in Blatt1 vergleichen.

Für xl sollten diese vielen Formeln kein Problem darstellen.

Antwort
von smalar, 23

Mach Dir für die gesuchten Zahlen ein paar zählenwenn Felder und gut ist:

=ZÄHLENWENN(A1:A10;"1337")

https://support.office.com/de-de/article/ZÄHLENWENN-Funktion-e0de10c6-f885-...

Kommentar von Hamu24 ,

Ich suche keine spezielle Zahl an sich, möchte einfach nur wissen welche zahl mehrmals vorkommt.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten