Frage von Gadget268, 53

Was für eine Excel-Formel kann zwei Zellen (B und C) verrechnen, wenn in Zelle A ein bestimmter Text steht?

Hallo zusammen

Wie kann ich in Excel eine Formel machen, die mir pro Zeile B?*10^C? rechnet, wenn in Zelle A? ein "a" steht und dann jedes Ergebnis addieren?

So, dass zum Beispiel bei "Bild1" als Ergebnis "110001" steht.


In zwei Formeln habe ich es geschafft:

E? = WENN(A?="a";B?*10^C?)

G10 = SUMME(E:E)


Das muss doch auch in einer relativ kompakten Formel gehen!

Vielen Dank

Gadget268

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 53

Als Matrixformel
=SUMME((A1:A9="a")*(B1:B9*10)^(C1:C9))

nach der Eingabe mit STRG+SHIFT+ENTER abschließen, dann bilden sich noch { } um die Formel

=SUMMENPRODUKT((A1:A9="a")*(B1:B9*10)^(C1:C9)) ginge auch

Edit: Was auch Suboptimierer ja schon beschrieben hat

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 43

Summier doch einfach über die Spalte E: =SUMME(E1:E9)

Ohne Hilfsspalte sähe das so aus: =SUMMENPRODUKT((A1:A9="a")*(B1:B9)*10^(ZEILE(A1:A9)-1))

Keine passende Antwort gefunden?

Fragen Sie die Community