Frage von Ghanasoccer, 53

Warum nimmt der Verweisoperator (SVERWEIS) meine Vereinigungen oder Schnittmengen nicht an?

Formel bisher ist teil einer Bedingten Formatierung:

=SVERWEIS(TAG(C4);($L$4:$L$8;$P$4:$P$8;$P$4:$P$8;$T$4:$T$8;$X$4:$X$8;$AB$4:$AB$8);1;FALSCH)=TAG(C4)

Über den Namensmanager habe ich es auch schon probiert :( klappt einfach nicht....

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Iamiam, Community-Experte für Excel, 43

lieber etwas umständlicher, aber übersichtlich? (nicht getestet):

=ODER(

SVERWEIS(TAG(C4);$L$4:$L$8;1;0)=TAG(C4);

SVERWEIS(TAG(C4);$P$4:$P$8;1;0)=TAG(C4);

SVERWEIS(TAG(C4);$T$4:$T$8;1;0)=TAG(C4);

SVERWEIS(TAG(C4);$X$4:$X$8;1;0)=TAG(C4);

SVERWEIS(TAG(C4);$AB$4:$AB$8;1;0)=TAG(C4)

)

Kommentar von DeeDee07 ,

Die Formel wird wohl leider ein NV! ausgeben, da Excel im Oder-Block nur mit Wahr oder Falsch zurechtkommt. Über Fehlerwerte stolpert es.

Das könnte man aber mit Wennfehler oder Istfehler abfangen.

Etwa:

=WENNFEHLER(SVERWEIS(TAG(C4);$L$4:$L$8;1;0)=TAG(C4);"") &

WENNFEHLER(SVERWEIS(TAG(C4);$P$4:$P$8;1;0)=TAG(C4);"")

& usw.

(Ich gehe dabei davon aus, dass der Sverweis nur 1x fehlerlos ist, sonst werden die Ergebnisse verkettet)

Kommentar von Iamiam ,

Danke für den Hinweis, an #NV! etc. hab ich nicht gedacht und Deine Lösung sollte funktionieren.

Ich würde allerdings als Alternativargument von Wennfehler einfach eine 0 nehmen, das sollte keine Probleme machen? Mags jetzt nicht mehr ausprobieren, bin heute schon vorzeitig müde... Ghanasoccer wird damit schon zurechtkommen, hat ja etwas mehr Hintergrund als ein Schüler im 1. oder 2. Jahr Inf.))

Kommentar von Iamiam ,

Ist schon spät, hab nicht mehr richtig gelesen:

ich würde das Wennfehler samt Vergleich ins Oder integrieren, im Prinzip wie in obiger Formel:

=ODER(

WENNFEHLER(SVERWEIS(TAG(C4);$L$4:$L$8;1;0)=TAG(C4);

WENNFEHLER(SVERWEIS(TAG(C4);$P$4:$P$8;1;0)=TAG(C4);

...

)

0=Tag(C4) sollte FALSCH liefern, andernfalls sollte der SVerweis ja wohl den Tag liefern, so interpretiere ich die Originaltabelle und das = dann WAHR.

und jetzt reichts wirklich, gute Nacht!

Kommentar von Iamiam ,

Daanke für den *, der bringt mein Konto wieder auf heute

34 HA in 32,29 Wochen seit Beginn der aktuellen Liste  und damit auf deutlich >50/Jahr ! (Experten-Grenze: als Xprt werden die AWs einfach eher akzeptiert im Autoritäts-gläubigen Deutschland)

Expertenantwort
von DeeDee07, Community-Experte für Excel, 53

Wie Ortogonn bereits schrieb, kann man in SVERWEIS nicht mehrere Bereiche als Suchmatrix setzen. Du könntest in eine ggf. versteckte Hilfspalte untereinander alle relevanten Bereiche ausgeben, also =L4, =L5 usw. bis =AB8. Dann verwendest du diese Hilfsspalte als Sverweis-Suchmatrix.

Kommentar von Iamiam ,

auch eine praktikable Idee!

Antwort
von Ortogonn, 45

Die Möglichkeit der Angabe von mehreren zu durchsuchenden Matrizen bietet SVERWEIS nicht.

Einziger Ansatz der mir einfällt ist

http://www.excelformeln.de/formeln.html?welcher=233

Bei dir sind es halt nicht verschiedene Tabellenblätter sondern Spaltenbezeichner.

Kommentar von Iamiam ,

Eine gute Parallele! Muss man erst mal drauf kommen!

Keine passende Antwort gefunden?

Fragen Sie die Community