Frage von Greensi, 55

Warum macht mein Ubuntu 15.04 keinen Neustart?

Hallo,

der Monitor wird zwar abgeschaltet, aber nicht wieder eingeschaltet und das System hängt scheinbar nach dem Runterfahren fest und kommt nicht wieder zurück. Woran kann das liegen?

Gruß, Greensi

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Linuxhase, 55

Hallo

der Monitor wird zwar abgeschaltet,

woran merkst Du das, wird er denn dunkel oder meldet er auch "kein Signal"?

das System hängt scheinbar nach dem Runterfahren fest

Wenn dieser Zustand eintritt, kannst Du noch mit Strg+ALT+F1 in ein Terminal wechseln? Ansonsten tippe ich mal auf Probleme  mit dem Power- Management.

cat /proc/cmdline
grep acpi /proc/cpuinfo
ps ax | grep acpi

Linuxhase

Kommentar von Greensi ,

Vielen Dank für deine Antwort.

Ich kann in diesem Zustand nicht mit Strg+Alt+Fx in ein anderes Terminal wechseln.

Kommentar von Linuxhase ,

@Greensi

Vielen Dank für deine Antwort.

Wo bitte bleiben die Antworten der ersten Frage und der CLI Abfragen?

Zur Not versuche in Runlevel 1 zu booten um die Kommandos absetzen zu können.

Linuxhase

Kommentar von Greensi ,

Was für CLI Abfragen meinst du?

Kommentar von Linuxhase ,
cat /proc/cmdline
grep acpi /proc/cpuinfo
ps ax | grep acpi
Kommentar von Greensi ,

Die sehen so aus:

1. BOOT_IMAGE=/boot/vmlinuz-3.19.0-31-generic root=UUID=4b45d01e-f6c7-4e2d-a433-b97a7bba1de0 ro quit splash

2. flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveoptflags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveoptflags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveoptflags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveopt

3.  

 67 ? S< 0:00 [acpi_thermal_pm] 

 929 ? Ss 0:03 /usr/sbin/acpid

18584 pts/2 S+ 0:00 grep --color=auto acpi

Kommentar von Linuxhase ,

@Greensi

BOOT_IMAGE=/boot/vmlinuz-3.19.0-31-generic root=UUID=4b45d01e-f6c7-4e2d-a433-b97a7bba1de0 ro quit splash

O.K. acpi wird nicht abgeschaltet und auch sonst nichts außer dem Spashscreen.

flags: pae acpi

Zeigt das Deine CPU auch acpi kann.

 67 ? S< 0:00 [acpi_thermal_pm]
929 ? Ss 0:03 /usr/sbin/acpid

Außer das bei mir die Parameter -n -f an den Dämon übergeben werden sieht es bei mir auch so aus.

Dann hat das schonmal nichts mit dem Energiemanagement zu tun, also woanders suchen, schau mal in die Logfiles:

grep -Ei 'error|fail' /var/log/syslog
dmesg | grep -Ei 'error|fail'

Linuxhase

Kommentar von Greensi ,

1. Oct 30 11:54:31 corei5 com.ubuntu.OneConf[1460]: WARNING:oneconf.hosts:Error in loading other_hosts file: [Errno 2] No such file or directory: '/home/andre/.cache/oneconf/dccbbec24815445b8ee450e9795d39e2/other_hosts'


2. [ 0.492995] ACPI PCC probe failed.


[ 1.659167] systemd[1]: Cannot add dependency job for unit gssproxy.service, ignoring: Unit gssproxy.service failed to load: No such file or directory.


[ 1.685014] systemd[1]: Dependency failed for pNFS block layout mapping daemon.


[ 1.685096] systemd[1]: Job nfs-blkmap.service/start failed with result 'dependency'.


[ 1.980278] nvidia: module verification failed: signature and/or required key missing - tainting kernel


[ 2.137075] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro


[12156.822191] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[12156.822192] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[12156.873832] tsc: Marking TSC unstable due to check_tsc_sync_source failed[20714.620044] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[20714.620045] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[29902.448044] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[29902.448045] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[30188.541686] cdc_acm 1-11:1.1: failed to set dtr/rts


[35759.762918] cdc_acm 1-11:1.1: failed to set dtr/rts


[39365.240045] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[39365.240047] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[51338.720044] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[51338.720045] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[67244.284042] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[67244.284044] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[85790.536043] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[85790.536044] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[90691.476046] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[90691.476047] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[93379.012042] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[93379.012044] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[108433.512042] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[108433.512044] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending


[118979.704045] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)


[118979.704046] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue suspending



Hm also da is ganz oben was mit ACPI. Vielleicht liegts daran? Ich vermute ja, dass es mal wieder mit nvidia zusammenhängt. ich weiß aber nicht, wie ich das überprüfen kann.

Kommentar von Linuxhase ,

@Greensi

Bitte verwende für Terminalausgaben die Code-TAGs oder lege das Zeug gleich auf einem Paste Dienst ab:

grep -Ei 'error|fail' /var/log/syslog | curl -F 'sprunge=<-' http://sprunge.usdmesg | grep -Ei 'error|fail' | curl -F 'sprunge=<-' (wie oben)

Damit bekommst Du, sofern Du eine Internetverbindung ahst, zwei Links zurück die Du hier bitte bereitstellst.

Linuxhase

Kommentar von Greensi ,

Mehr als 1 Link werden als Spam interpretiert.

1: http://nopaste.linux-dev.org/?798474

Kommentar von Greensi ,
Kommentar von Linuxhase ,

@Greensi

[    1.685014] systemd[1]: Dependency failed for pNFS block layout mapping daemon.
[ 1.685096] systemd[1]: Job nfs-blkmap.service/start failed with result 'dependency'.
[ 1.980278] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[ 2.137075] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[12156.822191] ieee80211 phy0: rt61pci_set_device_state: Error - Device failed to enter state 1 (-16)
[12156.822192] ieee80211 phy0: rt2x00lib_suspend: Warning - Device failed to enter sleep state, continue

Da fehlt zum einen eine Abhängigkeit und zum anderen gibt es offensichtlich ein Problem mit Deinem NVIDIA-Treiber und außerdem wird Dein /dev/sda1 nur read only eingehängt, es kann also nicht schreibend darauf zugegriffen werden.

grep -Ei 'error|fail' greensi_1
Oct 30 11:54:31 corei5 com.ubuntu.OneConf[1460]: WARNING:oneconf.hosts:Error in loading other_hosts file: [Errno
Oct 30 12:50:04 corei5 chromium-browser.desktop[1879]: [1879:1916:1030/125004:ERROR:channel.cc(307)] RawChannel
read error (connection broken)
Oct 30 13:05:58 corei5 gnome-session[1574]: Gjs-Message: JS LOG: pushModal: invocation of begin_modal failed
Oct 30 14:01:45 corei5 gnome-session[1574]: (eog:27938): EOG-WARNING **: Failed to open file
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init deviceinfo plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init proximity plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init time plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init alert plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init thermometer plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init deviceinfo plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init proximity plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init time plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init alert plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init thermometer plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: Failed to init gatt_example plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: Failed to init gatt_example plugin
Oct 30 14:34:56 corei5 bluetoothd[28403]: input-headset driver probe failed for device 94:35:0A:C7:1F:72
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: input-headset driver probe failed for device
Oct 30 14:34:56 corei5 bluetoothd[28403]: hci0: Load Long Term Keys (0x0013) failed: Not Supported (0x0c)
Oct 30 14:34:56 corei5 bluetoothd[28403]: bluetoothd[28403]: hci0: Load Long Term Keys (0x0013) failed: Not
Oct 30 14:35:00 corei5 colord[825]: (colord:825): Cd-WARNING **: failed to get session [pid 28387]: Unbekannter
Oct 30 14:35:00 corei5 colord[825]: (colord:825): Cd-WARNING **: CdMain: failed to read /proc/28387/cmdline
Oct 30 14:35:02 corei5 org.gnome.Calculator.SearchProvider[1460]: Error: ErrorCode.UNKNOWN_VARIABLE
Oct 30 14:35:03 corei5 org.gnome.Calculator.SearchProvider[1460]: Error: ErrorCode.UNKNOWN_VARIABLE
assertion 'GDK_IS_WINDOW (window)' failed

auch hier Fehler ohne Ende, bluetooth, gnome ect.

Ob eines dieser Probleme aber direkt mit Deiner Frage (Resatart) in Verbindung steht, das kann ich nicht mit Gewissheit sagen. Ich würde deswegen jedes dieser Probleme lösen um es als Ursache ausschließen zu können.

Leider kann ich speziell in diesem Fall nicht viel helfen, was auch daran liegt das ich kein Ubuntu verwende.

Linuxhase

Kommentar von Greensi ,

vielleicht könntest du mir dabei helfen, einfach mal den graka treiber zu deinstallieren und dann neu zu installieren. möglicherweise liegt es daran schon. ich hatte schon öfter probleme mit nvidia karten unter ubuntu.

wie würde man da vorgehen?

Kommentar von Linuxhase ,

@Greensi

wie würde man da vorgehen?

Das fängt schonmal damit an das man dafür eine eigene Frage stellt um letztlich auch die Übersicht zu verbessern.

Darin dann direkt mit den nötigen Informationen, betreffend des Problems bereitstellen.

Linuxhase

Antwort
von Jack63G, 47

Ich habe hier auch so ein System, was genau das selbe macht....  Herunterfahren geht, Kaltstart auch, jedoch Re-booten funktioniert nicht.  Die letzten Meldungen sagen eindeutig, dass alles korrekt beendet wurde, alle Prozesse beendet und alle Volumen dismountet wurden.  Die letzte Meldung, welche an der Konsole noch zu lesen ist lautet  ......rebooting        und dann ist das Videosignal weg, keine Tastaturabfrage mehr, es passiert einfach nichts mehr.  Kurz vom Strom getrennt, wieder verbunden und eingeschaltet startet das System ohne Probleme und fehlerfrei....

Die Ursache ist das BIOS in Verbindung mit der vewendeten Kernel und der daraus resultierenden Warmstart-Einsprungadresse, die ins Leere führt. Powermanagement, Standbymodus, Hibernation, Powerstates wurde alles als Ursache ausgeschlossen...

Was kann man da machen ? Diese Kombination wird nie funktionieren und mindestens eine Komponente muss geändert werden.  Entweder kann ein BIOS-Upgrade,  oder ein anderen Kernel / ein anderes System das lösen !  Eine andere Lösung für dieses Problem gibt es nicht und die Änderung o.g. Sachen ist dennoch keine Garantie, dass das Problem damit behoben ist. Das wird bestehen bleiben, solange der dafür verantwortliche Code erhalten bleibt....

Antwort
von MultiKingCong, 37

... vermutlich hast du den falschen Button gedrückt .. und das Programm abgeschaltet .. anstatt .. ' neustart ' .. versuch doch nochmal mit einschalten ...

dann sollte es auf alle Fälle wieder starten ...

.

Antwort
von Myhuky3, 36

Hast du Ubuntu als einziges system drauf oder ist daneben noch irgendein anderes os installiert?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten