Frage von mrmerida, 61

Warum gibt excel #NV als Ergebnis?

Hallo folgendes Problem In der Spalte A stehen lauter Datumswerte untereinander z.B. 01.01.2015 auch mehrfach das selbe Datum. In Spalte C stehen verschiedene Textzeichen (Kategorien) z.B. p für Privat usw.

ich werte mit folgender Formel aus wieviele Tage es in einem Zeitraum pro Kategorie gibt. wenn also an einem Tag 3x p gelistet ist, muss als Ergebnis 1 ausgegeben werden. Formel =SUMMENPRODUKT((((HÄUFIGKEIT(A2:A1337(C2:C1337="ws/as");A2:A1337)<>0)1)((MONAT(A2:A1337)=H170))((JAHR(A2:A1337)=G170))))

Diese Formel Formel funktioniert an sich ganz gut. Nur wenn in Spalte A leer Zellen vorhanden sind wird #NV als Ergebnis ausgegeben. Was muss ich an der Formel ändern, dass diese trotz leerer Zellen funktioniert.

Antwort
von safur, 52

Warum gibt es denn leere Zellen?

 

Vom Prinzip fragst du nach ISTNV ab und gibst dann 0 aus.
=WENN(INSTNV(DEINE_FORMEL) ; "0"; DEINE_FORMEL)

=WENN(ISTNV(
SUMMENPRODUKT((((HÄUFIGKEIT(A2:A1337(C2:C1337="ws/as");A2:A1337)<>0)1)((MONAT(A2:A1337)=H170))((JAHR(A2:A1337)=G170))))
);"0";
SUMMENPRODUKT((((HÄUFIGKEIT(A2:A1337(C2:C1337="ws/as");A2:A1337)<>0)1)((MONAT(A2:A1337)=H170))((JAHR(A2:A1337)=G170))))
)

Kommentar von mrmerida ,

Hallo Safur,

danke für Deine Hilfe, bringt mich aber leider nicht weiter. So erhalte ich bei leeren Zellen den Wert 0 anstatt #NV ich benötige aber den Wert der bereits eingetragenen Daten.

Die Zelle in der die Formel steht gehört zu einem monatlichen Report.

Die Zellen in der die Werte stehen also Datum und Kategorie, werden täglich oder wöchentlich mit Daten befüllt.

Vielleicht kannst Du mir ja trotz der Anforderungen helfen

Gruß

mrmerida

Kommentar von safur ,

Hast du einen Screenshot?
Welchen Wert (Zelle) brauchst du denn dann?

Für was brauchst du die Datensätze wo A=leer sind?

Kommentar von mrmerida ,

Hallo Safur,

hab es mit folgender Formel hinbekommen.

kann leider keinen Screenshot einfügen.

danke für deine Bemühung.

=AUFRUNDEN(SUMMENPRODUKT((A2:A15<>"")/ZÄHLENWENN(A2:A15;A2:A15&"")*((MONAT(A2:A15)=F3))*((JAHR(A2:A15)=E3))*((C2:C15)=E5));0)

Keine passende Antwort gefunden?

Fragen Sie die Community