Frage von H4RD5TYL3R, 95

Warum finden sich Geräte in meinem Netzwerk mit 2 Routern nicht untereinander?

Hallo Community!

Ich habe einen Telekom Router der sich ins Internet einwählt. und nutze eine Fritzbox als zweites WLAN Netzwerk. Die Fritzbox ist über LAN an den Telekom Router angeschlossen.

Der Internetzugriff funktioniert einwandfrei, doch ein paar Macken gibt es in meiner Konfiguration :

  • Geräte die mit Router 2 verbunden sind finden Geräte vom Router 1 nicht und umgekehrt

  • Geräte die mit dem Router 1 verbunden sind, können nicht auf den NAS Speicher zugreifen, der an Router 2 hängt.

  • Geräte die mit Router 2 verbunden sind, werden im Router 1 nicht getrennt angezeigt. (Umgekehrt sowieso nicht, aber das ist egal)

Ich denke, es liegt an einer Einstellung in der Fritzbox, doch an welcher? Muss ich bei der Fritzbox einen anderen DNS-Server eingeben? Muss ich vielleicht die Funktion "Statische Routingtabelle" nutzen?

Ich hoffe es gibt hier einen Spezialisten, der mir helfen kann.

Viele Grüße

Expertenantwort
von netzy, Community-Experte für Computer, Internet, Router, 42

http://avm.de/service/fritzbox/fritzbox-7390/wissensdatenbank/publication/show/1...

richte deine Fritte als IP-Client ein ;)

somit sind alle deine Geräte im selben Subnet, womit problemlos ein Zugriff der Clients untereinander möglich ist

ist dasselbe wenn du der Fritte eine statische IP außerhalb des Bereichs der DHCP-Range vom Gateway gibst und (ganz wichtig) DHCP bei der Fritte deaktivierst

die Fritte hat dann noch eigene Einstellungen wie z.B: "WLAN-Geräte dürfen miteinander kommunizieren" usw.......

Kommentar von H4RD5TYL3R ,

An einige Geräte die an dem Telekom-Router hängen habe ich keinen Zugriff. 

Ich habe jetzt im den Bereich des DHCP-Servers in der Fritzbox geändert und in den selben Bereich gelegt, in dem auch der Telekom Router arbeitet. Allerdings von 200-254, weil sich dort nichts stört.

Ich sehe jetzt alle verbundenen Geräte in der Fritzbox, auch die vom Telekom-Router. Zugreifen kann ich leider immer noch nicht über einen Router hinaus auf die Geräte.

Im selben Subnet müssten jetzt doch eigentlich alle Geräte sein oder nicht?

Kommentar von H4RD5TYL3R ,

Ach irgendwie klappt das alles nicht...

Kann ich die Fritzbox nicht einfach wie ein Switch einrichten?

Wenn ich nen Switch an den Telekom Router hänge und alle Geräte anschließe, funktioniert das doch auch.

Die Fritzbox fungiert doch auch nur als Switch, bis auf, dass sie noch WLAN bietet.

Kommentar von netzy ,

Ich habe jetzt im den Bereich des DHCP-Servers in der Fritzbox geändert und in den selben Bereich gelegt, in dem auch der Telekom Router arbeitet

dann dürfte dein Netzwerk nicht funktionieren ;)

nochmal, im selben Subnet darf NUR EIN DHCP-Server aktiv sein ;)

richte die Fritte im IP-Client-Modus ein, dann geht das alles automatisch und du brauchst nicht darüber nachdenken, vor allem kannst du dann nichts falsch machen, auch wenn du wolltest ;)

wenn dein Telekomrouter ein Speedport ist, dann sind alle deine Geräte im Bereich 192.168.2.xxx

Kommentar von H4RD5TYL3R ,

Also : DHCP Server der Fritzbox ist aus. Die Fritzbox hat jetzt die IP 192.168.2.254, der Telekom Router 192.168.2.1.

Nur muss ich jetzt die IP Adressen in den Geräten, die an der Fritzbox hänge ja manuell eingeben. Als Gateway soll ich jetzt den Telekom Router nutzen? Das funktioniert nämlich nicht.

Kommentar von H4RD5TYL3R ,

Ich merke gerade wie ich mir alles verkompliziert habe... Sollte jetzt laufen. Danke für die Hilfe!

Kommentar von netzy ,

Ich bin auf dem Gebiet eigentlich ziemlich fit, ich brauch nur einen Anstoß in die richtige Richtung

dann stoße ich dich mal in die richtige Richtung ;)

ALLE Geräte sind im Subnet 192.168.2.xxx und der DHCP-Server deines Speedport "versorgt"  ALLE Geräte per DHCP mit den richtigen IP-Adressen, egal ob diese per Kabel oder WLAN verbunden sind und auch egal, wo diese verbunden sind ;)

unter WIN kannst du ja einfach bei jedem Client mit "ipconfig /all" die Adaptereinstellung kontrollieren

statische IP-Adressen würde ich sowieso fixen Geräten zuteilen, da dies den Zugriff erleichtert, z.B: dem NAS, einer Spielkonsole, usw.

Gateway ist immer der Telekom-Router

Kommentar von netzy ,

Ich merke gerade wie ich mir alles verkompliziert habe...

manchmal denkt man nur zu kompliziert ;)

Kommentar von H4RD5TYL3R ,

Kann ich theoretisch auch den DHCP Server der Fritzbox nutzen und den des Telekom-Routers deaktiveren? Der Telekom-Router hat da nämlich manchmal seine Problemchen...

Kommentar von netzy ,

kannst du auch machen, solange nur einer läuft

Kommentar von H4RD5TYL3R ,

Gut, Danke! Das hier wird die Hilfreichste Antwort!

Antwort
von tactless, 41

Warum schmeißt du den Telekom-Router nicht aus deiner Konfiguration und nutzt nur die FritzBox? 

Kommentar von H4RD5TYL3R ,

1. Ist ein WLAN-Netzwerk zu schwach um das ganze Haus abzudecken.

2. Läuft unser VOIP nur über den Telekom Router und die Fritzbox unterstützt das nicht (Hardwaremäßig).

Ein neuer Router kommt nicht in Frage.

Antwort
von jofischi, 65

Meine Vermutung, für die FritzBox funktioniert der erste Router nur als Modem. Folglich können sich die Geräte untereinander gar nicht finden.

Kommentar von Ultimator2001 ,

Das ist FALSCH!

Kommentar von H4RD5TYL3R ,

Teilweise werden Geräte, die an Router 1 verbunden sind und mal am Router 2 verbunden waren, im Router 2 angezeigt.

Irgendeine Möglichkeit muss es doch geben.

Antwort
von Ultimator2001, 38

Ruf jemanden vom Netzwerk dienst die können dir gleich praktisch helfen.

Kommentar von H4RD5TYL3R ,

Nein, ich will niemanden anrufen. Ich bin auf dem Gebiet eigentlich ziemlich fit, ich brauch nur einen Anstoß in die richtige Richtung.

Kommentar von Ultimator2001 ,

ok

Kommentar von Ultimator2001 ,

Du musst die Funktion bei deiner Fritzbox ausschalten, die eigene IP adressen vergiebt (DHCP), dann ist dein Problem gelöst! (hopefully)

Kommentar von H4RD5TYL3R ,

Und welche IP-Adresse soll ich den Geräten dann zuteilen?

Kommentar von Ultimator2001 ,

statische

Kommentar von H4RD5TYL3R ,

Das ist mir klar. Ich hab den IP-Bereich jetzt auf den des anderen Routers gelegt, aber so das sich nichts in die Quere kommt. Nun sehe ich alle Geräte in beiden Routern.

Mit dem Zugriff auf den NAS-Server funktioniert es allerdings immer noch nicht.

Keine passende Antwort gefunden?

Fragen Sie die Community