Frage von Robo267, 76

Versionen?

Wenn ich ein Spiel programmiert und veröffentlicht habe dann beginnt es ja mit Version 1.0.0 Wenn ich dann ein Update mache ist die neue Version dann 1.0.1 ? Und geht das dann immer so weiter?

Antwort
von Venix5, 36

Die Frage ist eher, was du mit deinen Punkten trennst.

1.0.0 für die Orginalversion ist ok, wenn du weiternummerierst zu 1.0.1 für ein Update, stellt sich die Frage, wann möchtest du die zweite Stelle ändern.

Im Regelfall bedeutet die Positionen folgendes

a.b.c
a = Hauptversion, ändert sich nur wenn du das Programm fast neu programmierst
b = Nebenversion, ändert sich, wenn dein Update Neuerungen, Zusätze enthält
c = Revisionsversion, ändert sich, wenn dein Update nur Fehlerbehebungen enthält

Gruß
Venix

Kommentar von medmonk ,

Gut zusammengefasst! 

Mehr dazu: http://semver.org/lang/de/

Expertenantwort
von medmonk, Community-Experte für Computer, 34

Die Versionsnummer setzt sich aus den Major, Minor und Patch-Releases zusammen. Du solltest dich daher mal mit »Semantic Versioning« auseinandersetzen. Fürs erste sollte die von mir verlinkte Seite ausreichen:

Semantic Versioning: http://semver.org/lang/de/

LG medmonk 

Antwort
von SirSchinken, 33

Das entscheidet der Entwickler, Microsoft kann dir natürlich beim Zählen bis 10 behilflich sein:


http://trendingcurrentevents.com/wp-content/uploads/2014/10/Bill-Gates-Count-to-...

Kommentar von Willibergi ,

xD
LG Willibergi

Kommentar von KnorxyThieus ,

Der Witz ist gut, aber Off Topic. Ich hab mich daher für Dislike + Danke entschieden ;)

Antwort
von Fragenfrager3, 29

Wenn du 1.0 machst dann würde es so aussehen: 1.0 --> 1.1 --> 1.2 --> usw.

Wenn du mit 1.0.0 anfängst dann würde es so aussehen: 1.0.0 --> 1.0.1 --> 1.0.2 --> usw. und dann als weiter ( 1.1.1 --> 1.2.1 --> 1.3.1 ....)

Antwort
von FirstLegend, 6

Die Version kannst du beliebig angeben. Du kannst auch mit Version 2.0.0 anfangen.

Antwort
von Blobeye, 35

Die Benennung kannste selbst bestimmen. Sei kreativ ;)

Antwort
von UniX6, 37

Ja. Irgendwann biste bei 1.10 oder weiter.

Keine passende Antwort gefunden?

Fragen Sie die Community