Verschiebung einer Zelle je nach Bedarf?

... komplette Frage anzeigen

2 Antworten

Wenn die Posten in Spalte A stehen und die Bestände(Soll? und IST) in Spalte B und C, dann vor dem Ausfüllen zB in B5:

=wenn(Anzahl(A$1:A2)=Zeile(A2);"Unterschrift:";"")

und runterkopieren. Das setzt "Unterschrift:" mit 2 Zellen Zwischenraum unter die Bestandsspalten. Dass diese Formeln mit den Bestandszahlen überschrieben werden müssen, ist völlig egal, sie sind ja nicht sichtbar bzw eben nur in der einen Zelle, und für einen Ausdruck reicht das.

Leerzellen in der Liste oberhalb würden stören, es empfiehlt sich, sie mit je einem Leerzeichen zu füllen (aber natürlich nicht unterhalb der Posten!)

Du kannst soger noch unterhalb einen bedingten Rahmen oder eine Unterschriftslinie per bedingter Formatierung druntersetzen

oder aber mit gleicher Technik (obige Formel, aber zwei weitere Zeilen drunter) viele underbars.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
24.12.2015, 01:39

Letzteres nochmals genauer: Formel jetzt in B6:

=wenn(Anzahl(A$1:A3)=Zeile(A3);"Unterschrift:";"")&wenn(Anzahl(A$1:A3)=Zeile(A1);". . . . . . . . . . . . . . . . . . . . . . . .";"")

Da brauchst Du dann nicht mal eine bedingte Formatierung für. (von deren massenhaftem Einsatz ich ohnehin immer noch abrate)

0

Es geht anscheinend nur um eine Spalte, wenn ich es richtig verstehe. Man kann dort natürlich in jeder Zelle eine Formel hinterlegen, die prüft, ob sie quasi die letzte gefüllte ist. Das Problem dabei ist, dass die Formeln in der Zelle vor der letzten beim Erfassen der Daten überschrieben werden müssen. Das lässt sich dann nicht wieder rückgängig machen bzw. kommen dann die Formeln durcheinander. Zum Ausprobieren (gem. Deiner Vorgabe 4 leere Spalten zwischen letztem Eintrag und der Unterschrift:

=WENN(UND(ZÄHLENWENN(B$1:B5;"UNTERSCHRIFT")=0;ZÄHLENWENN(B2:B5;"")=4);"UNTERSCHRIFT";"")

Alternativ als bedingte Formatierung: Da kannst Du die Felder mit Rahmen, Farben was auch immer versehen, allerdings nichts reinschreiben. Die Formel wäre dann

=UND(C1<>"";ZÄHLENWENN(C2:C5;"")=4)
In C6 eintragen und entsprechend den Gültigkeitsbereich nach unten erweitern. Es muss, damit es funktioniert, zumindest ein Eintrag gefüllt sein

Es sind bewusst im Beispiel zwei unterschiedliche Spalten, damit Du vergleichen kannst.

Andere Lösungen wären noch mit VBA möglich, da müsstest Du aber sagen, ob Du da ran willst.

Antwort bewerten Vielen Dank für Deine Bewertung