Frage von DaGaertner, 45

verschachtelten wenn/dann/sonst Formel in Excel?

Hallo liebe Gemeinde,

Wie Eingangs erwähnt benötige ich eine Excel Formel.

Als Ausgang dient eine Variable Zahl.

Zur formen:

Wenn meine Zahl X größer ist als 120, dann 4, sonst 3, wenn Zahl x größer als 180, dann 5, sonst 4, wenn Zahl X größer als 240! Dann 6, sonst 5, usw.

Die bräuchte ich bitte als Excel Formel. Leider komme ich trotz youtube und Hilfe bei Excel nicht weiter, danke

Expertenantwort
von DeeDee07, Community-Experte für Excel, 31

Falls es eine Übung zur WENN-Verschachtelung ist, dann nimm die Formel von Herb.

Ansonsten kann man das auch anders lösen, z.B. so

=MAX(GANZZAHL(A1/60)+2;3)

(wobei hier die Zahl auch dann den Wert erhält, wenn sie nicht nur größer, sondern größer gleich der Grenzzahl ist. Um das zu beheben, kann man in der Formel eine winzige Zahl zur Berechnung abziehen etwa =GANZZAHL((A1-0,0000000001)/60)+2
)

Antwort
von Herb3472, 36

=WENN(X>240;6;WENN(X>180;5;WENN(X>120;4;3)))

Beginnen musst Du mit der größten Zahl.

Expertenantwort
von Oubyi, Community-Experte für Excel, 16

Dann "schmeiß" ich auch noch eine dritte Möglichkeit in die Runde:

=VERWEIS(A1;{0;121;181;241};{3;4;5;6})

Falls auch Kommazahlen vorkommen können, müsstest Du die erste Matrix anpassen, z.B. 0;120,0001; usw.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten