Vergleich zweier Excel Tabellen?

... komplette Frage anzeigen

3 Antworten

Du kannst dafür einen normalen SVERWEIS verwenden (sofern die Telefonnummern links von Art stehen).

Falls Telefonnummern in Spalte A und Art in B stehen:
=SVERWEIS(A1;[dest_code.xlsx]mappe1!$A$1:$A$1001;2;FALSCH)
Bei nichtvorhandenen Nummern wird NV! ausgegeben.

Falls die Telefonnumern rechts von Art stehen, dann verwendest du statt des SVERWEIS die Kombination INDEX(VERGLEICH).

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo :),

schau mal nach den Funktionen

=SUCHEN()
und
=FINDEN()

Das wären die Formeln die du benutzen kannst =)

Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
23.03.2016, 16:07

Bei SUCHEN und FINDEN kann das Argument Text kein Bereich sein, afaik. Höchstens in einigen Matrixformeln bzw. SUMMENPRODUKT o.ä.

1

In Tabelle B zu jeder Telefonnummer

=zählenwenn(TabelleA!A:A;B1)

Wobei TabelleA! halt die andere Datei sein soll und der Suchbereich Spalte A ggf. auch anzupassen ist.

Damit markierst Du die Telefonnummern in B, die bereits in A vorhanden sind (die liefern eine 1). Die mit 0 müssen kopiert werden.

Alternativ: Komplette Liste von B und A kopieren und dann Ribbon Daten > Dubplikate entfernen


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von riuwalker
23.03.2016, 13:49

Ich wäre jetzt so vorgegangen: 

=WENN(IDENTISCH(C3;[dest_code.xlsx]mappe1!$A$1:$A$1001);1;2)

klappt leider nicht. Er soll eben die Nummer aus der Zelle c3 mit allen Nummern (A1-A1001) aus der anderen Tabelle vergleichen. Wenn es die Nummer gibt soll erstmal eine 1 geschrieben werden wenn nicht dann eine 2

0

Was möchtest Du wissen?