Frage von decentr, 56

Vario 1 / 2 / 3?

Hallo liebe Excel Experten,

Ich bräuchte mal en Formel für Excel '2007' den ich mit meiner wissen nicht fertigen kann, Also;

A1=1 B1=2 C1=3

D1= WENN(A1>0;A1; 》》 ich will hier noch einfügen WENN(B1 irgendwelchezahlsteht;B1 wennnichtA1 und WENN (C1 irgendwelchezahlsteht;C1 wennnicht B1 auchwennB1 nichtzahlstehtA1))))

Ich glaube nicht das es so kompliziert für excelkenner ist..

Danke im Voraus

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von DeeDee07, Community-Experte für Excel, 56

Meinst du das so?

=WENN(C1<>"";C1;WENN(B1<>"";B1;WENN(A1<>"";A1;"")))

Die Priorität ist dann C1, B1, A1, leer.

Kommentar von decentr ,

Wenn A1 =Belegt andere uninteressant wenn B1= Belegt andere uninteressant wenn C1= Belegt andere uninteressant Wenn A1= 1 B1 und C1 soll A1 nicht stören ich will nur 1 sehen wennB1= 2 was in A1 steht soll mich nicht stören ich will nur 2 sehen wennC1=3 A1=1 B1=2 soll verschiedenen ich will nur 3 sehen wenn nirgendwo nichts steht ""

Kommentar von DeeDee07 ,

Puh, ganz schön schwer zu entziffern ohne Interpunktion.

Was soll denn z.B. stehen wenn A1 und B1 belegt sind, oder wenn in allen 3 Zellen etwas steht? Denn das widerspricht sich ja, bzw. ist mehrdeutig.

Kommentar von decentr ,

Wenn A1 etwas steht nur A1 wenn A1 und B1 etwas stehen nur B1 A1 und B1 und C1 stehen überall was Dann nur c1

Kommentar von decentr ,

Arbeitszeit A1= 08:00 - 12:00 = 04:00 Std. AA1= 4 Stunde 》 Wenn nur bis 12:00 Uhr B1 = 13:00 - 15:00 = 02:00 Std. AA1= 6 Stunden Wenn nur bis 15:00 C1= 16:00 - 18:00 = 02:00 Std. AA1= 8 Stunde Wenn bis 18:00 uhr

Kommentar von decentr ,

DeeDee07 hast du was für mich?

Kommentar von Iamiam ,

ich werd da zwar überhaupt nicht schlau draus, aber hast du schon mal die Summe dieser ZeitDifferenzen gebildet?

Kommentar von DeeDee07 ,

Schau mal, hier gibt es etliche Leute, die wahre Experten im Bereich Excel sind. Auch ich habe inzwischen einige bescheidene Kenntnisse auf diesem Gebiet erworben.

Wir helfen den Usern hier freiwillig und unentgeltlich bei ihren Excel-Fragen und -Problemen, zum einen weil man gerne hilft, zum anderen weil man Spaß hat an einer Problemstellung rumzuknobeln und eine passende Lösung zu finden.

Aber es ist frustrierend, wenn man merkt, dass wenig Mühe in die Frage gesteckt wurde (keine klare Strukturierung der vorhandenen Gegebenheiten, keine Mitteillung was bereits versucht wurde, mangelnde Rechtschreibung und Satzbau usw.). Da ist man dann auch nicht mehr so bereit, sich weiter anzustrengen.

Das ist nicht böse gemeint, es ist nur ein Vorschlag, wie man auch dem Antwortenden helfen kann.

...

Eine verschachtelte Wenn-Abfrage (wie oben in der Antwort) arbeitet mit Prioritäten. Wenn ich also lese

Wenn A1 =Belegt andere uninteressant

dann breche ich ab, sobald in A1 etwas steht. Ob dann in B1 oder in C1 noch was steht, ist ja uninteressant. Aber in den nächsten Sätzen soll es doch wieder berücksichtigt werden? Das ist nicht eindeutig.  Was steht denn in den Zellen überhaupt drin? Arbeitszeiten? Stundenanzahlen?

Stelle klare Prioritäten zusammen, ohne Widersprüche, mit eindeutigem Inhalt. Das erleichtert uns die Aufgabe enorm.

Kommentar von decentr ,

Also, sorry bis Jetzt war ich über Smartphone.

Kommentar von decentr ,

Hier noch mal;

A1=1

B1=2

C1=3

ich würde vom Excel sowas verlangen

D1=WENN(A1<0;A1;"";WENN(B1<0;B1;A1;"";WENNC1<0;C1;B1;A1;"")

damit wäre mein Wunsch;

Wenn die Zelle B1 und C1 "0" oder leer ist D1= 1

Wenn in Zelle B1 ein zahl steht(z.b. Spiel 2 ) D1=2

Wenn in Zelle  C1 ein Zahl steht(z.b. Spiel 3) D1=3

Beispiele,

1;

A=  

B=

C=

D= 

2;

A=1

B=

C=

D=1

3;

A=1

B=2

C=

D=2

4;

A=1

B=2

C=3

D=3

bedanke mich noch ein Mal im Voraus

Kommentar von decentr ,

Sorry noch mal, zu mein befehl noch mal; anstatt <,> 

Kommentar von DeeDee07 ,

In der Eingangsfrage standen Zahlen (1, 2, 3) drin, jetzt Spiel1 usw. Letzteres wäre keine Zahl, sondern ein Text. Die Formel aus meiner ersten Antwort sollte leicht abgewandelt funktionieren.

=WENN(C1<>"";3;WENN(B1<>"";2;WENN(A1<>"";1;"")))

Die von dir vorgeschlagene Formel ist fehlerhaft; sie hat zu viele Argumente.

Kommentar von decentr ,

Du bist gut, ich kann mich nicht richtig ausdrucken was ich will... Formel von vorgestern wäre; =MAX (A1:C1)

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 35

Mach dir mal in Excel eine Entscheidungstabelle

A B C Ergebnis
0 0 1 0 1 0 0 1 1 1 0 0 1 0 1 1 1 0 1 1 1 ...
  • Diese Visualisierung wird dir helfen, Uneindeutigkeiten zu finden und Regeln zu definieren.
  • Wenn du das hast, kannst du uns ja nochmal einen Screenshot posten.
  • Um was für Typen von Daten handelt es sich überhaupt? Das zu wissen könnte dem Verständnis zuträglich sein.
  • Du kannst probieren, deine Formel zunächst auf mehrere Zellen zu verteilen und die Zwischenergebnisse dann zusammenzufassen. Mir hilft das jedenfalls häufig. In vielen Fällen ist eine Monsterformel nicht notwendig.
    Die Zeilen / Spalten mit den Zwischenergebnissen kannst du auf ein anderes Tabellenblatt später schieben und dieses Verstecken oder du versteckst die Zeilen / Spalten.
  • Lässt sich dein Szenario eventuell vereinfachen, um etwas zu haben, auf das man später aufbauen könnte? → Geh schrittweise vor.

Eins kann ich dir schon einmal versprechen: Ist die Logik dahinter geklärt, wird es für Excel der Aufgabe gewachsen sein. Es muss nur sichergestellt sein, dass die Abzweigungen konsistent sind.

Kommentar von decentr ,

nix verstanden. Danke Trotzdem

Kommentar von Suboptimierer ,

Dann trotzdem bitte für Nix
Wahrscheinlich habe ich zuviel geschrieben...

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten