Frage von Maskera, 71

Undefinierte Excel Zelle...?

Hallo zusammen, ich bin bei Excel auf ein kleines Problem gestossen. Ich habe undefinierte Zellen in meiner Mappe, welche aber zum Rechnen gebraucht werden. Wie die undefinierten Zellen zustand kommen ist mir schon klar (Division durch 0), ich möchte jetzt allerdings, dass mir z.B. eine "=WENN" Formel dies angibt und zu einer Zahl oder Text umformt. Ich würde mir das so vorstellen: =wenn(A1="undefiniert";0;A1) -> Also =Wenn die Zelle A1 undefiniert ist, schreibe undefiniert, ansonsten entspreche der Zelle A1. Danke für alle Antworten und Hilfestellungen!

Expertenantwort
von Iamiam, Community-Experte für Excel, 46

=WENNFEHLER(A1;1)

ausgedeutscht: wenn in A1 ein Fehler auftritt, dann nimm 1 ansonsten nimm A1

Es kann dabei aber nicht die Art des Fehlers spezifiziert werden.

Expertenantwort
von Oubyi, Community-Experte für Excel, 34

Mit WENNFEHLER kannst Du ganz leicht alle Fehler abfangen.
Z.B.:
=WENNFEHLER(B1/C1;0)
Wenn Du spezielle die Division durch 0 abfangen willst, solltest Du das allerdings so machen:
=WENN(C1=0;0;B1/C1)

Kommentar von Iamiam ,

wie einfach, wie schlicht, und doch so ergreifend...

ich hab nämlich gestern vergeblich versucht, noch sowas wie =Fehler(Typ) zu finden!

Kommentar von Oubyi ,

sowas wie =Fehler(Typ)

Das gibt es, soweit ich weiß, leider nur ISTNV und ISTFEHL, das alle Fehler außer #NV abfängt.

Antwort
von Sawascwoolf, 31

ich glaube ed gibt eine formel namens istfehler oder so

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten