Frage von MrCube1997, 533

Ubuntu 16.04 funktioniert nicht mehr nach Nvidia Geforce 540m Grafikkartentreiber Installation?

Hallo, ich hab heute versucht einen Nvidia Treiber für meine Grafikkarte über das Terminal herunterzuladen und installieren.

Als die Installation abgeschlossen war funktionierten keine Anwendungen mehr und als ich mich Abgemeldet hatte konnte ich mich auch nicht mehr anmelden.

Ich hab den PC dann herunter gefahren, jetzt ist das Problem das der Bildschirm beim Start schwarz bleibt.

Ich versuche schon zum 2. Mal vergebens einen Treiber für meine Grafikkarte zu intallieren da meine Spiele sonst immer die von Intel verwenden.

Weiß irgendwer was ich machen kann/soll?

Expertenantwort
von Linuxhase, Community-Experte für PC, 353

Hallo

ich hab heute versucht einen Nvidia Treiber für meine Grafikkarte über das Terminal herunterzuladen und installieren.

  1. Warum denn nicht den aus dem Repository verwenden
  2. Oder ist für diese hochaktuelle Version noch kein passender Treiber verfügbar?
  3. Wenn letzteres, dann hast Du es verdient, denn damit ist absolut zu rechnen wenn man nach wenigen Tagen schon die neue Version installiert!

Als die Installation abgeschlossen war funktionierten keine Anwendungen mehr

Welche denn und wie äußert sich das genau?

als ich mich Abgemeldet hatte konnte ich mich auch nicht mehr anmelden.

  • War da kein Anmeldedialog oder wie genau ist das abgelaufen?
  • Hast Du es mit einem anderen Benutzer probiert?

Ich hab den PC dann herunter gefahren, jetzt ist das Problem das der Bildschirm beim Start schwarz bleibt.

Dann gehört der freie Treiber wahrscheinlich auf die Blacklist, z.B. indem Du mit dem Kernelparameter nomodeset startest.

Ich versuche schon zum 2. Mal vergebens einen Treiber für meine Grafikkarte zu intallieren

Er IST doch bereits installiert, da bringt es auch nichts die Installation zu wiederholen. Schau mal nach:

lspci -nnk | grep -iA3 vga

Was steht da steht bei Kernel Driver in use?

Linuxhase

Antwort
von Barris, 317

Es ist bekannt, hat also wenig damit zu tun, dass es ein sehr junges Ubuntu ist - der Nvidia-Treiber aus offiziellen Quellen kommt mit Dualgrafik (oft bei den Laptops ab Mittelklasse) nicht zu recht und der Bootscreen erscheint nicht.

Es hilft, in den Startoptionen den Kernel-Parameter "nomodeset" hinzuzufügen. Danach wird ein einfacher Treiber geladen, das System startet und Ubuntu sollte einen proprietären Treiber vorschlagen und installieren lassen.

Antwort
von androhecker, 345

Du kannst in einer anderes Fenster wechseln wenn du STRG+ALT+(Eine F-Taste) drückst, auf 7 ist Standardmäßig X. Und du brauchst für Nvidia Karten keine Treiber zu installieren, die funktionieren unter Ubuntu mit X auch mit dem vorinstalliertem.

Kommentar von MrCube1997 ,

Bin mit STRG+ALT+F7 zur Anmeldung gekommen, wenn ich mich anmelde komm ich statt auf den Desktop wieder zur Anmeldung

Kommentar von androhecker ,

Geh auf F1, dann hast du eine Konsole.

Kommentar von MrCube1997 ,

Ok, und dann?

Kommentar von androhecker ,

Dann entfernst du den Treiber wieder.

Antwort
von PhotonX, 285

Du hast wahrscheinlich eine .run-Datei von der nVidia-Webseite heruntergeladen und sie ausgeführt, oder? Das ist ein sehr häufiger Fehler, den Windows-Umsteiger am Anfang machen. :) Unter Linux gibt es für das Installieren und Deinstallieren von Software (inklusive Treiber) die sogenannte Paketverwaltung. Unter Ubuntu gibt es dafür das Software Center (es ist ein grafisches Frontend für die Paketverwaltung). Speziell für Treiber gibt es auch den Treiber-Manager: https://wiki.ubuntuusers.de/Zus%C3%A4tzliche%20Treiber/#Grafische-Benutzeroberfl...

Entferne also den den via .run Datei installierten Treiber mit der "--uninstall" Option, also etwa wie

sudo blabla.run --uninstall

und benutze den Treiber-Manager.

Kommentar von MrCube1997 ,

Von der nvidia Seite hab ich keinen Treiber runtergeladen, ich habs mit apt-get install versucht Ich bin ein kompletter Linux Anfänger, möchte es aber unbedingt verwenden können

Kommentar von PhotonX ,

Ok, dann schau bitte, was dir "grep EE /var/log/Xorg.0.log" ausgibt.

Kommentar von MrCube1997 ,

Ich versuche mit STRG + Alt + F1 auf die Konsole zuzugreifen aber wenn ich einen Befehl eingebe passiert nichts

Kommentar von PhotonX ,

Hast du dich denn auch eingeloggt?

Kommentar von MrCube1997 ,

Ich hab mich bei der Konsole eingeloggt, danach nimmt sie aber keine Befehle an

Kommentar von PhotonX ,

Was passiert denn, wenn du einen Befehl eingibst?

Kommentar von MrCube1997 ,

Garnichts, der Befehl steht dann einfach da und nichts passiert

Kommentar von PhotonX ,

Was passiert denn, wenn du

echo "Hello World!"

eingibst?

Kommentar von Linuxhase ,

@MrCube1997

der Befehl steht dann einfach da und nichts passiert

Aber Du hast nach der Eingabe des Kommandos schon die ENTER bzw. RETURN Taste gedrückt oder?!

Wie sieht denn Dein Prompt aus?

Beispiel:

mrcube1997@ubuntu # 

Linuxhase

Kommentar von MrCube1997 ,

Auch nix, ich habs jetzt einfach neu installiert, mich stört nur dass für alle Anwendungen die Intel Karte genommen wird und nicht die von Nvidia

Kommentar von PhotonX ,

Schau mal hier (du brauchst PRIME bzw. Bumblebee): https://wiki.ubuntuusers.de/Grafikkarten/Nvidia/

Kommentar von MrCube1997 ,

Hab auch gerade herausgefunden dass Nvidia Optimus nicht auf Linux läuft, kann ich Prime oder Bumblebee unter Ubuntu 16.04 verwenden?

Kommentar von MrCube1997 ,

Habs installiert, nach nem Neustart bekomm ich nen blackscreen den ich nur mit Alt GR + F7 beheben kann und wenn ich bumblebee verwenden will bekomm ich auch nur eine Fehlermeldung

Kommentar von PhotonX ,

Hast du auch alle Schritte, die nach der Installation zu tun sind, ausgeführt?

Kommentar von MrCube1997 ,

Ich hab die bumblebee.conf geändert und den pc neu gestartet, danach haben die Probleme angefangen

Kommentar von PhotonX ,

Auch die /etc/modules? Und auch die anderen Befehle ausgeführt?

Kommentar von PhotonX ,

Sorry, ich lese gerade in der zweiten Antwort, dass es unter 16.04 wohl doch anders (und viel einfacher) geht: http://askubuntu.com/a/758995/270792 Tut mir Leid!

Kommentar von MrCube1997 ,

Also soll ich es mit prime versuchen statt bumblebee?

Kommentar von PhotonX ,

Genau, du müsstest jetzt die soeben gemachten Änderungen alle wieder rückgängig machen und stattdessen die beiden Pakete, wie in der verlinkten Antwort beschrieben, installieren.

Kommentar von MrCube1997 ,

Ok, danke, würde es reichen einfach bumblebee zu deinstallieren?

Kommentar von PhotonX ,

Angeblich kann man auch beides zugleich installieren (siehe Kommentar zur ausgezeichneten Antwort).

Antwort
von Barris, 246

Der "Standard-Treiber" für Nvidia

Keine passende Antwort gefunden?

Fragen Sie die Community