Frage von DerChacker, 40

Ubuntu 15.10 bootloader hat sich verabschiedet?

Kumpel von mir, hat von Ubuntu 15.10 das 16.04 Upgrade gemacht.

Problem: Ubuntu lief immer im Dual Boot und schien weg zu sein, da sich Windows startete. Die boot Reihenfolge wurde dabei nicht verändert.

Startet er Ubuntu 16.04 Live vom USB bootet Ubuntu wie gehabt (15.10) mit allen Nutzerdaten, also ist es auch noch da. Entfernt man USB und bootet neu hat man wieder nur Windows.

Da Ubuntu 15.10 aber noch mit allen Nutzdaten da ist schätze ich mal dass sich der Linux Ubuntu boot loader verabschiedet hat, warum auch immer.

Wie behebt man das nun?

Antwort
von roffermann, 24

Starte nochmal von USB, so das Du wieder in deinem alten Ubuntu bist. Öffne dann das Terminal und gib dort "sudo update-grub" ein. Sollte das nicht klappen und der Bootloader von Linux erscheint nicht, dann nochmal per USB starten(Du mußt in dein altes System kommen ! - also wenn Du nur ein Live-system gestartet hast kommst Du in dein eigenes System indem Du im Livesystem einen Terminal öffnes und dort erstmal dein eigenes System mountes mit "sudo mount /dev/sda? /mnt" - (Das Fragezeichen steht für die Laufwereksnummer). Diesen mountbefehl bitte für beide Laufwerke-die / und /home. Es gibt keine Laufwerke in Linux _ ich weiß_ die nennen sich anders. Dann mußte Du in dein eigenes Laufwerk wechsel mit dem Befehl " sudo chroot /mnt" - Jetzt bist Du im eigenen System und reparierst deinen Grub-bootloader mit " sudo grub-setup /dev/sda".

PS. Um deine genaue Laufwerksbezeichnung (Nummer) feststellen zu können kannst Du im Livesystem - geparted - aufrufen, dort werden alle Laufwerke aufgeführt.

Sowas kann man alles nachlesen in den Seiten von "Ubuntuusers.de" ←merken!!!

Gruß Goofy

Kommentar von DerChacker ,

Das Terminal sagt: can't find /dev/sda5/mnt in /etc/fstab

Kommentar von roffermann ,

Du hast das Leerzeichen vergessen /dev/sda /mnt

Kommentar von roffermann ,

Ich habe die 5 vergessen - doch danach kommt ein Leerzeichen

Kommentar von DerChacker ,

Ok, die bash gibt aber leider immer noch die selbe Fehlermeldung aus

Kommentar von roffermann ,

Eventuell solltest Du mal diese Fehlermeldung Googlen und gucken welche Berichte dazu ausgegeben werden. Ich kenne diese Meldung auch, weiß aber jetzt nicht mehr wie ich dies behoben habe. Also läßt sich dein eigenes System nicht mounten ?

Das kann man aber irgentwie hinkriegen. Hast Du also die Liveversion eingespielt? Also beim Hochfahren auf Ubuntu ausprobieren geklickt und diesen Befehl " sudo mount /dev/sda5 /mnt" probiert ! ? Zwischen sda5 und /mnt muß ein Leerzeichen rein. Guck bitte auch mal hier nach und lese es dir durch : https://wiki.ubuntuusers.de/chroot/Live-CD/

Das a in sda könnte auch falsch sein, das kannst Du aber mit gparted feststellen. Mit Hilfe von Ubuntuusers kannst Du den Fehler finden und beheben. !!! Das werden wir schon hinkriegen !!!

Goofy

Kommentar von roffermann ,

Versuche mal "sudo grub-setup /dev/sda" direkt auszuführen, also ohne das wir dein eigenes System mounten. Oder auch "sudo update-grub". Es könnte auch klappen wenn Du nur in deinem Live-system bist. Ich glaube damit hatte ich früher mal Glück, zu Zeiten zu welchen ich noch keine Ahnung von allem hatte. Danach starte dein System neu und prüfe ob der Ubuntu-bootloader erscheint. Goofy

Keine passende Antwort gefunden?

Fragen Sie die Community