Frage von dukeball, 32

Teil 2 welche Formel in Excel muss ich nutzen?

Hallo da ich mich im ersten Teil der Frage ein bißchen Unklar ausgedrückt habe, habe ich meine Formel hier eingefügt:

ZÄHLENWENN(C7:C26;"X")+ZÄHLENWENN(C7:C26;"V")/2)+ZÄHLENWENN(C7:C26;"N")/2)+ZÄHLENWENN(C7:C26;"SA"))

das ganze soll aber nur geschehen, wenn im Bereich, hier Spalte B in der jeweiligen Zelle ein r steht. Mit der Wenn Formel wird nur eine Zelle abgeglichen; aber hier soll jede Zelle im Spaltenbereich abgeglichen werden.

Angenommen in Spalte b3 und b7 steht ein r; dann soll die zählenwennfunktion greifen; sonst nicht.

Vielen Dank.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von schmiddi1967, Community-Experte für Excel, 29

Kann es sein das du das so meinst, teste diese mal:

=ZÄHLENWENNS(C7:C26;"X";B7:B26;"r")+ZÄHLENWENNS(C7:C26;"V";B7:B26;"r")/2+ZÄHLENWENNS(C7:C26;"N";B7:B26;"r")/2+ZÄHLENWENNS(C7:C26;"Sa";B7:B26;"r")
Kommentar von Oubyi ,

DH!

Alternativ aber nicht besser sondern nur Geschmackssache (Ich bin Fan von SUMMENPRODUKT):

=SUMMENPRODUKT((B7:B26&C7:C26="rX")+(B7:B26&C7:C26="rV")/2+(B7:B26&C7:C26="rN")/2+(B7:B26&C7:C26="rSa"))


oder, ohne die Code-Funktion dargestellt (finde ich in manchen Fällen übersichtlicher):

=SUMMENPRODUKT((B7:B26&C7:C26="rX")+(B7:B26&C7:C26="rV")/2+(B7:B26&C7:C26="rN")/2+(B7:B26&C7:C26="rSa"))

Antwort
von iMPerFekTioN, 27

Hallo, dann solltest du deine ganze Formel als DANN-Wert (2. Teil der WENN-Funktion) in eine WENN Funktion packen.

D.h. nach deiner Vorgabe hier;

=WENN(UND(B3="r";B7="r");ZÄHLENWENN(C7:C26;"X")+ZÄHLENWENN(C7:C26;"V")/2)+ZÄHLENWENN(C7:C26;"N")/2)+ZÄHLENWENN(C7:C26;"SA"));"Nichts")

So würde das dann funktionieren, deine Formel wird nur aufgerufen, wenn in B3 UND B7 ein "r" steht!

Wenn du das aber für jede Zeile haben willst, sprich in B1 ein r dann wird in C2 die Formel ausgeführt usw, dann nimmst du halt anstatt dem hier:

=WENN(UND(B3="r";B7="r");ZÄHLENWENN(C7:C26;"X")+ZÄHLENWENN(C7:C26;"V")/2)+ZÄHLENWENN(C7:C26;"N")/2)+ZÄHLENWENN(C7:C26;"SA"));"Nichts")

Nur das hier:

=WENN(B3="r";ZÄHLENWENN(C7:C26;"X")+ZÄHLENWENN(C7:C26;"V")/2)+ZÄHLENWENN(C7:C26;"N")/2)+ZÄHLENWENN(C7:C26;"SA"));"Nichts")

Liebe Grüße,


iMPerFekTioN

Keine passende Antwort gefunden?

Fragen Sie die Community