Frage von dervogtler, 32

Syntax einer Zelle abgleichen?

Hallo,

ich würde gerne mit =WENN überprüfen, ob die Zelle XX. XX.XX XX.XX.XX enthält. XX steht hier für eine beliebige Nummerierung (01, 01.02, usw). Ich bin vermutlich gerade einfach zu blöd, dass wieder bei google zu finden, da ich das schonmal gelöst habe; stehe aber gerade unter Zeitdruck.

Vielen Dank für die Unterstützung.

Expertenantwort
von Iamiam, Community-Experte für Excel, 24

es scheint sich um eine Nummerierungs-Ebenen-Abfrage zu handeln.

=Länge(A1)-Länge(Wechseln(A1);".";"")

liefert Dir die Anzahl der Punkte. Dabei ,üssen die Nummern nicht 2-stellig sein.

Kommentar von dervogtler ,

Top Work-around! Danke

Expertenantwort
von Oubyi, Community-Experte für Excel, 20

Teste mal:

=WENN(ZÄHLENWENN(A1;"??. ??.?? ??.??.??")>0;"passt";"passt nicht")

(Sind die zwei Leerstellen an 4 und 5 Absicht?)
Es wird allerdings nicht geprüft, ob statt Ziffern Buchstaben die Wildcards füllen. Ist das auch noch nötig?

Kommentar von dervogtler ,

ZÄHLENWENN war hier das Zauberwort. Vielen Dank für den Tipp, habe die Formel noch etwas angepasst, aber grob war das die Richtung *Daumen hoch*

Kommentar von Oubyi ,

Gern geschehen 😉
Freut mich, dass ich helfen konnte.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 26

Du musst leider die Trennzeichen an den Stellen vergleichen und Gesamtlänge überprüfen. Excel kennt (ohne VBA) keine regulären Ausdrücke.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten